function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Package unabailable.

I created a package in my developer account and uploaded it. I was trying to install it in my org account, but I get the following error:
"This package is not yet available. Please wait, or contact the package owner."

I have uploaded the same package many times before and this is simply the latest version. I added a few triggers since the last version, but nothing substantial. I have experienced temporary delays before, but not this long (24 hours).

If I try and install the package back into my developer account (on 'na5'), it finds it. If I try to install it in my second developer account (on 'na2'), I also get an error. My org account is on the 'ssl' server.

I will try uploading it with the same elements as in the last working version and see what that does.

Any other ideas? Thanks in advance.

Here is a screenshot for one version of the error:

Here is a screenshot for a similar error I got one time, even though I was trying to upload the same elements as above:
Best Answer chosen by Admin (Salesforce Developers) 
Can you try this again.  This issue should be resolved now.

All Answers

Here is an update on the above issue:

I tried to install a previously uploaded version of the package that I had already successfully installed in my org account. In my org account and my 'na2' developer account, I get the same error as in the first screenshot.

I have the same problem.

Ok, so everything works now. I didn't do anything to fix it. Any new packages I upload go through just fine. I think that maybe Salesforce put some Drano in the pipe.
Working for me now too.  Thanks.

I'm having the same problems again! I uploaded a package 11 hours ago and it is still unavailable. I am getting the error from the first screenshot. Please help, I neeed to be able to deploy packages within the usual 15 minutes or so, not days later.
For some reason, it now works on cs2 (sandbox) and na2 (developer), but still not on ssl (org).
I am getting the same problem in our sandbox (tapp0). I use the installation link sent in the upload successful email, changing "login" to "test" for the sandbox. I get the error from montblanc2000's first screenshot.
Salesforce Tier 2 Support says that this is a known issue and they are working on it. I don't know exactly how long it will be, but I get the impression that they will have it fixed within the next few days to a week. Here is a temporary workaround that may help (it didn't for me, but try anyway):

(1) go to the package installation URL

(2) login

(3) append the URL with &crc=1

(4) it should now work

This is a temporary fix that Salesforce gave me, but it did not work for me. I got a screen similar to the second screenshot in this post, but the ID of the package was known rather than blank.

It's now October (almost), so presumably Salesforce's Drano has lost its fizz, because the same thing is happening to me and my colleagues this week: 

I have a package, developed and uploaded from a Developer org, in Managed-Released state.  It was uploaded last week, so it's hardly brand new.

Using the package URL (not yet 'exposed' on AppExchange), I have successfully installed this package on two other orgs - another Developer org and a Production org.

I tried to use the same package URL, replacing '' with '', to install the package on a Sandbox.  It fails, with the following msg (as also reported elsewhere in this thread):

AppExchange Package Unavailable
The following AppExchange package is not yet available for install: {0}.  Please try again in a few minutes.

I tried appending '&crc=1' to the URL, as suggested in this thread, to no effect.

It's not something that has suddenly happened to the package itself.  The URL still works when I try installing it on another non-Sandbox org.  As I said, my colleagues are having variants on the same problem when trying to install pkgs (other pkgs) onto Sandbox orgs.

What's going on??  It smells to me like something's gone wrong with the packaging infrastructure.  If anybody in the know is trolling this thread, could you weigh in and let us know what the story is?  Judging by the huge number of hits this thread has gotten already, I suspect there are a LOT of clients out there silently struggling with the same issue.



Hi Philbo,

The Salesforce Drano is still flowing nicely. The predicament you're in has to do with the fact that certain salesforce sandbox instances are now live on Winter '09. Once the instance where you uploaded your package is upgraded to Winter '09, you will then be able to install it into all other orgs running on Winter '09.

The details about sandbox, packaging and the release are covered in the following post:

All instances will be live on Winter '09 within the next two weeks, so you should be all set by then. Oh, and the Salesforce Drano is being thrown out in Winter '09 in favor of a new set of pipes - packaging is on an entirely new architecture starting this release!

Product Manager Platform

Hi there, I'm having a user with this same problem; is this an issue that happens every year -- perhaps you're transitioning over to a new Winter 2010 instance?  Is there anything we can do to help?  Specifically, a user is trying to install our application here:


However, he's getting the "This package is not yet available.  Please try again later or contact the package owner."  Per those instructions, he's contacted me (the package owner) but I don't know what to tell him.  The package has been available for over six months and is widely used.  (It's also in the Force 40.)  Any suggestions?



Expensify: Expense reports that don't suck 

Can you try this again.  This issue should be resolved now.
This was selected as the best answer

We have had a report of a client with this error today whilst installing our CountryComplete package from


I don't know which instance they're on as to whether they're on a Spring '10 or Winter '10 release.




Joel Mansford



Same issue (This package is not yet available) discovered this morning with a client of mine trying to do installation.   I am unable to reproduce the issue in a sandbox.  




I'm really without an answer for them.   


Working on collecting the details now.    Any insight would be helpful.  




My client is on NA1, we tried to install in to our LMA org (also NA1) and got the same error.  So not sure if it's just NA1 or Spring '10 in general 
My client is on spring 10 as well, but was not able to get the server out of them.   I have an open case with Salesforce support. 

Can you please provide your install URL (example below) and the instance in which you are trying to install the package (na1, na6, na7, etc). 

They are on na1.   This was last tested around 9AM PST today.  

Just to be clear, ours is being installed directly from our AppExchange listing at - I don't have the package URL to hand.


We encounter the error installing to our own partner org which is on NA1.  One of our customers alerted us to the error yesterday (15 Feb '10 approx 15:00 UTC) who is also on NA1.


I hope that helps.

Brent MellowBrent Mellow

Seems like this problem is continuing to persist.  I've been developing an application in a DEV org.  I have successfully uploaded 19 versions and installed them into a EE production org.  When I got to the 20th upload of the package, I still get the confirmation emails, but after more than 1 1/2 days, the package is still not installable.  I get:


Package Not Found The requested package does not exist or has been deleted. Please contact the package publisher for assistance. If this is a recently uploaded package, please try again soon. 


I even created another package in the same org and just added one custom field and it can't be found either.  I REALLY need to get the package installed.


What is the answer for this?





Brent Mellow




I am seeing a similar issue here with a recently uploaded package:


Invalid Package

This package is not yet available. Please try again later or contact the package owner.


I will open a case on the Partner Portal.