function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Packaging Bug?

I created a package 3 weeks ago and succesfully uploaded it. Yesterday I went back in to upload it again and noticed 3 lines at the top with no information except for "Included by":

When I click upload I get the following error messages:

I have searched for those field identifiers in the pages they supposedly belong to with no success.Clicking on the Name yields a message:

Data Not Available
The data you were trying to access could not be found. It may be due to another user deleting the data or a system error. If you know the data is not deleted but cannot access it, please look at our support page.

Click here to return to the previous page.

I have no pending field deletes. I am logged in as administrator with rights to do everything in this development account.

Does anyone have an idea of what's going on and why the display is so useless?


I am getting this identical behavior. I was able to find enough information to know that the links under the blank lines are to fields I have earlier deleted from custom objects. I have even gone in and permanently deleted the fields. I have tried deleting and recreating the package. Nothing works. This is definitely a bug in the packaging.

And it is stopping progress.

Someone from needs to jump in and fix this.

David Claiborne
Hell yes! And now!
If fields have been fully and irretrievably deleted (as they have) there is no reason whatsoever for the packaging to be "holding on" to the reference. There is nothing further we can do to eliminate from the package that which is already gone.
We logged a case with support last Wednesday and have heard...nothing.
Mauricio Parra
Wisconsin Alumni Research Foundation
Madison, Wisconsin
Hi All,

I apologize for the issue you two have hit.  We're in the process of investigating the root cause.  Can you please send me your case numbers so I can follow-up on them and check the status?  My email address is  I don't have an estimate yet of when this will be fixed as we are still diagnosing the issue.

Again, so sorry for the trouble this may have caused you.

Andrew Smith
Sr. Product Manager Platform
Thinking more about the problem led me to think where else were the deleted fields used - aha - in the object list views criteria.
Even though the deleted field was no longer in the criteria, it was apparently still tied.
So I edited all the list views for the two objects with the mystery fields and saved them. Actually, I did not make any changes, just opened for editing and saved.
Then mystery fields were then removed from the package.
There is still a bug, but you should know where to look now.

Good find! That took care of it for us too.

Mauricio Parra
Wisconsin Alumni research Foundation
Madison, WI

Many thanks -- this solved my problem as well.

A Custom object View that referenced in its filter Foo equals "bar" except I had deleted Foo has a custom field.  Deleting the View solved the packaging issue

Was this issue ever resolved?  We are trying to delete a managed package and we receive the "data not available" error message.  There is no further information to help debug the issue.  Our managed package is quite large, so I'm at a loss as to how to attack a hit-or-miss strategy to determine the component that is causing the problem. 

We thought we might try to upload a new version to see if it would "clean up" any possible issues with the current version, but when we try to install, we get the following error: "Your requested install failed.  Please try this again."

We have opened a case, but we are at a total standstill until we can resolve this issue.  Any suggestions?


Hi Morgan,

Can you please post your case number?

Hi Andrew,
Case: 02198025