+ Start a Discussion

Package Problem: What is going on?

    I have a MANAGED BETA  package with a few objects, classes and triggers.

    I install it successfully in a sandbox with no problem.

    I am able to use this package and the objects in the package....but then...

    suddenly and inexplicably, the objects that were part of the package disappear. When i look at "View Installed Packages", I still see my package but when I look at the entries
    inside the package, it just shows the classes and triggers - the actual OBJECTS have vanished!!

    This has happened at least 3 times.

    I have another object X defined in the sandbox that references object Y defined in the package. The reference to field Y also disappears in object X!!

    Interestingly, when I reinstall the package,  this reference REAPPEARS auto-magically - but of course I have lost all the reference data, since all objects of type Y have        disappeared as well.


Message Edited by GoForceGo on 07-03-2008 08:15 AM

I also am experiencing identical behavior. I install a BETA managed package into the sandboxI upload data. I verify everything is visible and working. The next day the objects disappear from the tabs.

The  managed package is still isted as installed, sys admin user has all the appropriate permissions but
I can't see the objects in my managed package the next day. I have reloaded twice now and same disappearing act the next day
Plese help...this is very frustrating and timing wasting.
Ron HessRon Hess
Please file a bug report / open a case with support
We have been experiencing a similar problem here since the beginning of July.  I filed a case on 4th of July but haven't heard anything back from SF since then.  I am even having hard time to get the update of the status of this case from their tech support.
I filed another case...


Here is the update received today -


The issue that you are encountering is a bug that we've discovered in the package uninstall/re-install process. From the case notes, it appears that you have noticed some objects disappearing after a certain period of time. This behavior is indicative of the issue we've discovered and are working to fix.

Specifically, this issue occurs when you install, uninstall, and re-install the same package within a short period of time (approximately 24 hours). When this occurs, some objects are being removed the night after the re-install.

We have identified the root cause of this issue and are working on a fix for a future release. If all goes well, we hope to have this fix by the end of this week. However, as with any bug fix, this could be delayed depending on the test results and planning for this proposed fix.

In the meantime, there are a couple of workarounds that can be used in the meantime:

1. After uninstalling the package, wait a day to re-install the package.
2. If this is a managed package, upgrade the existing package instead of uninstalling and re-installing the package.

Thanks for the update!

Is there any mention of this happening only in Sandbox?  Sounds like it could happen in production as well.

In my case, I think the first time objects disappeared, I hadn't uninstalled - it was the first install when they disappeared!

Also, I am not sure what they mean "at night". I think my objects disappeared at different times while I was working with them - once it was overnight.


This problem was first seen on the sandbox, actually, it occurred on all sites - sandbox, production, as well as developer's.

I tried to trace down the exact time when the objects disappeared and found that it started between 23:30 and 1:30EDT.


I am going to try the first workaround today.


Hi mikeosf, GoForceGo, tecumseth@north,
I apologize for the issue you have experienced.  We have diagnosed the problem and have a fix in the works that should be released shortly.  
As mentioned above, this issue occurs when you install, uninstall, and re-install the same package within a short period of time (24 hours).  We have two possible workarounds:
1. If this is a managed package, try upgrading the existing package instead of uninstalling and re-installing the package.
2. If the package has already been uninstalled, wait 24 hours before re-installing.
Again, I apologize for the trouble we have caused you and thank you for your patience.  If you could please post your case numbers, I’ll make sure we follow-up with you individually.  
Thank you,
Andrew Smith
Senior Product Manager
Force.com Platform

Message Edited by A_Smith on 07-16-2008 09:50 AM
Andrew, thanks for your response....the case number we have logged on this is
Subject: Case 01987501
Cheers Mike
Andrew, thanks for the post.

Case # 01986778


Can anybody confirm if this issue has been resolved?

I am getting this problem too. I un-installed the Print Anything package and tried to re-install it and the install fails. I did this on 16 July, it is now 29 July and i still can't get the package installed.

I have logged a case and have had no reply - Case Number: 02011605

Please if anybody maybe has another work around i would really appreciate it.



Hi Rudster,
I filed a ticket with support and the fixed the problem in our Sanbox.
Don't know if its been fixed system wide or in our porduction environment....
Hope this helps
Hi All,

The issue you are experiencing is actually a separate problem related to uninstall.  We have a fix in the works that should be released by tonight.  Please try uninstalling the package again tonight.  Note:  It may take up to 48 hours for your packages marked as "Pending" to be reset so you can try the uninstall again.

Hi Andrew,
Thanks for the quick response...
I tried again to install the Print Anything package and it failed again. I uninstalled the package on 16 July, i have been trying to re-install the package since friday 25 July (a week later). The only other package installed is AJAX. No other packages display in the View Installed Packages section in SF.
I have logged a second case as i have had no response on the first. New Case number: 02017333
This is getting a rather pressing matter now as the customer is getting impatient.
Please let me know what is going on.
Thank you for you help so far.