function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Assigned license needed to upgrade a package ?

The upgrade of one of our existing packages failed until I added a user license to the package for the user who runs the install.


Even when he is a system administrator this seems to be necessary. The admin is not necessarily one of the users of our application.


Is it true that you need an assigned license to upgrade a package ?

I never noticed that and may need to document this for our customers.


Maybe this can be shown to the user before starting the install instead of sending a cryptic "Install failed..." email.



Message Edited by Forcecode on 04-02-2009 04:48 AM

The user who installed the upgrade, is this the same user who installed the app originally? I would think the original installer would already have a license of your app.





I did a fresh install of our app and deployed it without assigning a license.


Then I did the upgrade with the same user (sys admin) and it failed.


When I assigned a license under "Manage Licenses" to this user for the app, the upgrade went through.



I know of two customers who have bought licenses but the admin is not working with the app and has no license assigned to his user under "Manage Licenses". Should he temporarily switch a license to himself when doing the upgrade ?






We tested this internally, and did not encounter an error. The scenario was install as Sys Admin and then upgrade, without assigning a license. That was successful. The create another user that is a Sys Admin and use this to upgrade, without assigning a license. That also worked successfully.


We suspect it could be your package, please log a case in the Partner Portal, so we can further investigate.






I reproduced the error again and it works if you select "Ignore apex test failures..", so it must have something to do with our test methods when there is no license assigned.


In the error message there was no hint of a test failure, only the standard error message.


Are you interested in this and should I log a case anyway ? I think I can live with this.


I would definitely log a case on this if you still are able to reproduce it.  Sounds like the Apex tests somehow need a user and can't execute if that user has no license to the package.  Are you able as that same admin to successfully run apex tests for the entire org after the package is installed? 


There is no error when I run the apex tests for the entire org after an upgrade.

Logged a case: 02562775


We had a similar issue. We had a user on a trial. The trial ran out and the user bought. We changed the license to active with the paid for number of seats. As a sysadmin, the user could not even install the new version package until he first gave himself a license to use.


You would a system admin could upgrade a package even if they were not a user of it...but it didn't work for us.