function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Eclipse Toolkit Synchronization Issue When Creating Trigger

I just had a weird problem when creating a new trigger on a custom object in my testing sandbox. I fired up Eclipse and opened my SF project, and all was well. I had added a couple of custom fields to my Contact object, but the schema was updated to reflect that. I had no error messages at that point.

Then I created a new trigger on the custom Membership__c object, setting it to fire After Insert, After Update, After Delete, After Undelete. The purpose of the trigger is to update the custom fields in the Contact object, making no changes to the child (lookup) Membership object.

But then the toolkit gave me an error, preventing me from saving the new trigger to the sandbox: "Conflict found while saving trigContactMembershipInfo.tgr. Remote instance has been updated since last save or sync. Use the Synchronize Perspective to resolve the conflict." I checked in SF, and the new trigger didn't yet exist on the Membership object.

So I tried explicitly sync'g, but the error wouldn't go away. When I deleted the new trigger, everything sync'd fine.

I have admin rights in SF and can author Apex code, so that's not the problem.

The only thing that finally worked was to create it using the toolkit wizard as a Before Insert trigger, then manually change the signature for the events I needed. Then I could save the trigger, no problem.

Any thoughts about why this is happening?

Hey Don.

Yeah, this is interesting - how changing the trigger operations enabled saving.

A couple questions:

- After you installed the latest toolkit, did you recreate your projects?
- Can you send me the toolkit's log containing your deployment transaction?  You can find the log here: $workspace/.metadata/.plugins/com.appexchange.toolkit/salesforce-toolkit.log.

Hi Chris,

This was a new installation of both Eclipse 3.3.0 and the toolkit, so I had no projects to recreate.

I found the log file and am emailing it to you.

I'm having similar problems.  For some reason the project always gets out of sync.  Attempts to override server with local copy results in an error message:

An internal error occurred during "". 

Doesn't give much to go on.  Deleting from salesforce is the only solution I've found.
Hey jeremy_r.

Can you set logging to 'debug' and re-run your scenario?  Finally, send me the log.

To do so, you’ll need to
- extract /log4j/log4j.xml from $eclipse/plugins/com.appexchange.toolkit_<version>.jar
- edit log4j.xml as shown below
<logger name="com.salesforce.toolkit">
    <level value="debug"/>
- finally, re-add the file keeping it's filepath (/log4j/log4j.xml) intact

You can find the log here: $workspace/.metadata/.plugins/com.appexchange.toolkit/salesforce-toolkit.log.