+ Start a Discussion

Push Upgrade - Not Working

I cannot seem to push upgrades to my subscribers.

The version;
- Is a managed release (not beta)
- Has passed security review
- Is up on the Appexchange

The application;
- Is Apex Certified
- Has the Aloha Status

The development org;
- Has push upgrades enabled
- Has pushed upgrades in the past
- Can push upgrades up to version 2.2.2
- The latest version is 2.2.7

Can anyone else see anything that I may have missed out here? These push upgrades are a pain!!!

Best Answer chosen by Admin (Salesforce Developers) 

Can you please send me a private message with your username for the packaging org?  I'll take a look.

All Answers


What is not working? Are you able to upload the patch version from the patch org? Or is the actual push failing to be distributed to the subscriber orgs? What modifications are you making in the patch release? 


I am trying to push the uploaded patch (now 2.2.9) to my subcribers but the version isn't available for selection in the eligible version list.


I'm am pretty sure I have done everything that is required. I've been able to push previous versions just fine.


Any clue why I might be having trouble here (using the info that I supplied in my first post)?


Have you uploaded v2.2.9 from the patch org? Was it successful? If it was successful, you are not seeing it under Setup -> Create -> Package -> package name -> Versions -> Push Upgrades and the drop down titled 'Version Number'?


Sorry to ask simple question - just trying to walk through all the steps and see where something went wrong. 


Yes, 2.2.9 is fully uploaded, uploaded to the AppExchange, security reviewed, updated on Trialforce and successfully installed on various test orgs.


And it still doesn't show up on the eligible versions. Neither has any version down to 2.2.2.


I've submitted various cases on this but never came to a solution.


Thanks. So when you go to 'Schedule Push Upgrade' , you do not see the patch version 2.2.9 listed under Patch Version dropdown? You don't see any patch versions listed? 


No. I see version 2.2.2 eligible for organisations with 2.2.1. That is all.


What I want to be able to do is select to schedule an push upgrade for 2.2.9 but the option just isn't available in the drop down list.


Have you deprecated 2.2.8?  If so, try undeprecating it and see if 2.2.9 becomes available.  


Undeprecated all the versions between 2.2.9 and 2.2.2.

Still no change:



Can you please send me a private message with your username for the packaging org?  I'll take a look.

This was selected as the best answer
Kakoo SonKakoo Son
my clients have the same problem last week on https://cscportal.in/ I think he found the solution, check out now