function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Unable to install appexchange apps into sandbox orgs



When I try to install an app from appexchange and select sandbox as my destination org, it would not put me into the right location. Is there a problem with the AppExchange?






I am not sure, but this might be the case for you.


Salesforce administrators and users with the “Download AppExchange packages” permission can install AppExchange apps.


Please check the above permission for your profile.






I'm sys admin. I contacted support and they said that even if I select the Sandbox org as the destination for my install, I need to login to the production org first and then when it prompts me for the second time, I need to login to the Sandbox org. How would I know that I don't know and I didn't think that this has always worked this way.


Of course it is strange. 


Thanks for sharing the solution :)





There's another way to do this... which worked for me yesterday


When it gives you the optipn to "login to Appexchange using your credentials", click on that, then on the next screen change the address in the address bar from to and continue with the login.


That should work!


It seems none of the ways mentioned above work for me today. It doesn't ask for second login and if I change login to test in URL, it throws auth error. Anyone able to get around?

Zahir PenthraZahir Penthra

I also face the same problem. i am not able to install a free app to my sandbox its asking for the normal login .. I am able to install the same app in my developer org. please advice what is the workaround for this.


Yes, it has worked for me @dawid ! many thanks....


In case anyone else is having this issue and for my own future reference this worked.


  1. First login to Appex with your main account (ie. not sandbox).
  2. Find the app you want to install in sandbox and click the "Get it now"
  3. You will be asked if you want to install the app in Production or Sandbox
  4. Choose sandbox and you will be automatically redirected to the
  5. Enter in your salesforce sandbox credentials
  6. Now just follow on screen isntructions.


That should be it. Hope this helps someone else out there.

madhu navulurimadhu navuluri
> Select the app
> Click "Get this App"
> From the Login screen use your Production Administrator Username and Password
enter your developer org credentials in that screen

> You will be asked if you want to install in Production or install in Sandbox
> click on install in sandbox and enter sandox credentials and click on install
> You will then be in the Sandbox install area and can continue

it has worked for me
Jonathan Meltzer 8Jonathan Meltzer 8
I have different permissions in the Sandbox from what I have in our Production org, I think.  In Production I may not have the ability to install apps, but in the Sandbox I might.  How can I get to install into the Sandbox if it is using my Production credentials to verify whether I can install the app?
Gerrit Straughter 10Gerrit Straughter 10
The Help article below solved the problem for me. Basically, you can log into ANY production org (including your own developer org where you are full sys admin) and then chose to install the app into a Sandbox, then enter the credentials for whatever Sandbox you wish. The Sandbox doesn't have to be connected to the production org at all.
Andreea Capata 16Andreea Capata 16
This app can't be installed.
There are problems that prevent this package from being installed.
(Clean_Assessment/Clean_Assessment_Tab.jpg) Data Storage Limits ExceededYour company currently has exceeded its data storage limits including an extra overflow buffer. Per our terms and conditions, we cannot permit additional data creation within our system until your company first reduces its current data storage. Please contact your company's administrator to resolve this. We apologize for any inconvenience this may cause.
Andreea Capata 16Andreea Capata 16
This is the error i am getting when trying to installl.Any suggestions?I have tried emptying some space but i feel that this should not be an issue since this is my trailhead dev accound
Hemal Nanavati 3Hemal Nanavati 3
Thank you @Gerrit Straughter 10

Your suggestion worked for me, however it is strange - logging into another developer environment worked but not the one I was actually trying to login and install the AppExchange App.