function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Scott FraserScott Fraser 

Deploying CustomField changes for standard objects using IDE

Has anyone had any success in deploying CustomField changes to the User or Task standard objects using the IDE?

For the User object, I'm getting the following error message:
  unable to obtain exclusive access to this record

For the Task object, I'm getting the following error messages:
  Field 'Subject' in 'Task' is not a picklist field
  Entity Enumeration Or ID: bad value for restricted picklist field: Task

I have been able to deploy changes on the Account and Opportunity, but have been unsuccessful in deploying to User and Task objects.

Bill EidsonBill Eidson
  Scott -

  There is an issue with Task record type deployment (which is what you are seeing); this issue will be fixed in a few days.  Note that the custom fields for Tasks will be on the Activity object, though.
  Regarding the User object, can you please contact me offline so I can gather more information about the problem (if you could send me the User.object file, that would be helpful).


  - Bill
Dogen ZenjiDogen Zenji
I'd like to resurrect this thread to see if the original poster's problem was ever solved.  I am getting the exact same error when trying to deploy custom fields for the Opportunity object.  Custom fields for Account, OpportunityLineItem, Product2 and User pass the Eclipse deployment validation but not Opportunity.

Never mind.  There was a target picklist field that had the same name as a source text field.  Deleting the target field allowed the Opportunity object to deploy.

Message Edited by Dogen Zenji on 08-28-2008 12:48 AM
Scott FraserScott Fraser
Yes, both of these issues were resolved.  I guess Bill and I talked about it offline and I forgot to update the discussion thread.
Can you tell me what was the Solution for this issue. I'm facing same issue with my CONTACT Standard object. I'm able to deploy all other standard object's custom fields but not the Contact Object.
Bill EidsonBill Eidson
  VChaddha -

  Sounds like a different issue as the original issue was specific to Task/Event.  I've sent you a private message; please contact me offline & we'll troubleshoot.


  - Bill

I have a form on my website that uses the API to submit a lead to I have some lead triggers (before insert, after insert) that act on that lead and convert it to a contact.

I have found that when validating a deployment of code from sandbox to production, or actually deploying, I can generate an Apex error by trying to submit to that form.

The error I get is:

ONEN_LeadToCampaign: execution of AfterInsert

caused by: System.DmlException: ConvertLead failed. First exception on row 0; first error: UNKNOWN_EXCEPTION, unable to obtain exclusive access to this record

Trigger.ONEN_LeadToCampaign: line 192, column 52

All tests are passing and the code deploys fine and runs fine in production once there, but doesn't allow lead inserts during validation or deployment.

Is this expected behavior for an API integration to fail during validation of deployment or an actual deployment?

we're looking into this now, we'll post an update soon.

thanks for the details...
Hi Steve,

I just emailed you for more details on this issue. Let's follow this offline till we locate the cause and find the solution.