function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Package uninstallation problem .

Hi All ,


I have a managed package installed in sandbox. I have also developed some custom code there. Now when I am trying to uninstall the package, I am not able to do so. It says "This extension depends on the package you are trying to uninstall."


I have checked that I am not using any reference of that managed package in my code. However, in eclipse I realized that meta.xml files of my apex classes are using the name space of that managed package. When I try to remove namespace from my meta.xml files it reverts my changes automatically.


I want to uninstall that managed package urgently.


Any help would be apreciated !!


Anyone from Salesforce listening???


I have the same issue - new Apex classes are creating dependancies to all installed managed apps even though the code does not reference these apps.  This happens right after the class is created so there is no code that could even reference another class.  The Show Dependencies button says there are no dependencies so clearly SF is able to determine if there are or are not dependencies on other packages.


I do not remeber this happening before the sandbox was upgraded to Spring 13. 


Is this a bug or by design?  Anyway to prevent or remove these dependencies (no you can't edit them out of the metadat file, they come right back automatically)?


Have you logged a case via the partner portal ( If so, can you please post the case #? 


Did log a case and SF Support explained that the "Version Setting" updates that were being added to our classes did not create a dependency on those 3rd party packages.  


The behavior of adding the references in the XML file (Eclipse IDE) to each installed 3rd party package is definetly new behavior in Summer 13.  Did some testing to ensure the direction I was getting from support was correct and was able to prove to my client (and me) that suppoer was in fact correct. Did the following tests:


1. Install new 3rd party package in sandbox but not production

2. Create new Apex class in sandbox - references to the newly installed 3rd party app were added to the Version settings of my new class.

3. Deploy the class to production


Class deployed just fine even though the 3rd party app identifed in the version settings was not present.


Then I uninstalled the 3rd party app from the sandbox without making any changes to the Apex class and that too worked just fine.



Joshua Davies.ax1788Joshua Davies.ax1788

I ran across this same issue myself and I figured out what the problem was.  I had two packages, one of which I had already released as a managed package, and I added a beta package to its org to test it out.  Then, when I tried to uninstall the beta package, I got this error.  It turned out that the way to get rid of the error was to release a new version of the managed package (that didn't reference the beta code), and THEN uninstall it.  Feels like a bug in salesforce to me (since I had removed all references to the beta package but was unable to uninstall until I had uploaded a new version of the managed package), but it worked when I did it.