function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Cannot specify a gender for a gender neutral language

I am having the following problem while trying to deploy a custom object through the eclipse tool.

Any ideas?

Deploy Results:
   Name:    unpackaged/objects/Business_Trip_Meeting__c.object
   Action:  NO ACTION
   Result:  FAILED
   Problem: Cannot specify a gender for a gender neutral language

Bill EidsonBill Eidson
 The gender field is in the XML file for languages with gender -- that must be the case for the source organization's language, but not the target.

Yes, I fixed it yesterday. Thank you anyway for your reply.

Looks like when u want to deploy from one system that is using a system language that has genders (for example spanish) to another one that has not (i.e. English) then you get this error.

After changing the language on the preferences I was still getting the errors since the gender info wasn´t erased form the XML definition... I got crazy until I founf that... and then everything worked perfect.





Can you please elaborate the solution for this problem?

 I am also getting the same problem while deploying a custom object.

The custom object name is in French but all fields under it are in English.



Bill EidsonBill Eidson


  .. sent you a private message, will work through this offline and post the solution once we've got one.



Can you please share the solution?  I am also getting the same problem when deploying.

Thank you

Bill EidsonBill Eidson

  Sorry, I forgot to follow up on this -- it was a couple years ago, so I don't remember what the specific issue or solution was.  Feel free to either post or private-message more details of your specific situation and the error you are getting, and I'll help to resolve it.

POC developerEditionPOC developerEdition
Can you specify how to access th XML file for languages with gender? Where is its location?
Abhiram GandikotaAbhiram Gandikota
The <gender> tag will be present in the custom object definition XML - in the MyCustomObject__c.object file. Just remove the tag and redeploy - it should work. 
Hi, we got the issue too from one org that was setup in Spanish to one that was in English. The thing is that the XML tag is always generated when you setup an object with a language with gender. As English does not have gender the tag was not there. Our solution was quite simple, change the target org to Spanish, make the deployment and switch back again. Is not a beautiful solution but works. There are no considerations about changing this 
Hello, I know this thread is a little old but i want to share the way I solved this same problem. 

Go to Eclipse and look for the object you are trying to deploy in the other instance.
right click > open (or F3 in my case)
on the bottom of the file opened in Eclipse you will see the field "Gender"... right click and choose "remove"

Save the file (ctls + s) and deploy again.
Open custom object in Eclipse

Remove "Gender" field

(you can save it local and don't  save to server, it will deploy fine with just saving it local) 
The error is due to a setting at the company information level : default language.
You need to align the environment language with a language that accept gender (spanish, french).
I have tested that and this has solve the error deployment without modifying the package information
Lynda Elbay 6Lynda Elbay 6
You have to set your Default Language and Default Locale on the company information should be same between the source environnement and the target environnement. 
Best regards