function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Cannot install Eclipse toolkit at all?

Hi there,

I am following the instructions from

and yet I cannot install Eclipse toolkit.

When I get to step 7, it gives this error message:-

Apex Toolkit for Eclipse ( requires plug-in "org.eclipse.wst.sse.core".

Please can some one help me. I have installed Eclipse version.

Please advice.


I ran into the same problem a couple of weeks ago.
Without really knowing how Eclipse add-in "packaging" works, I suspect the Eclipse toolkit depends on something that's ou-of-date or something like that.

How did I get around it? I just checked off every available add-in listed on the page and it installed ok. =)

Is there anyone working on the Eclipse toolkit present here?


Message Edited by JohanLiljegren on 01-01-2008 07:55 AM
There will be good news later today on this subject, stay tuned.

That's the main page, it links to new installation instructions, etc. Note that the name of the toolkit is now the Toolkit for Eclipse, not the Apex Toolkit.

I would advise a clean install with Eclipse 3.3 Java Developers edition.
Hi there,

I had a chance today to install Eclipse install from the new install

On step 8, I get this error;-

Network connection problems encountered during search.
  Unable to access "".
    Unable to access site: "" [Server returned HTTP response code: "404 Not Found" for URL:]
    Server returned HTTP response code: "404 Not Found" for URL:
    Unable to access site: "" [Server returned HTTP response code: "404 Not Found" for URL:]
    Server returned HTTP response code: "404 Not Found" for URL:

It seems that each time I download eclipse some plugins are always missing. Not sure, how to get these additional plugins from ?

Any ideas?
It appears you have two issues, the first one might be solved by trying again. I don't know why you would get a connection problem, the site is up and other people have downloaded the toolkit.

Now the second issue, missing plugins, that's covered in the Troubleshooting section on the installation wiki (scroll down).

I feel you on this issue, I had some problems at first as well. If you choose Eclipse for Java Developers, you'll get most of the enabling features. If you choose a vanilla Eclipse install, you will need to enable other plugins. See the images and explanation in the troubleshooting section.

If you are still having problems, please describe exactly what you're doing, maybe I can help more.
I will try this now.

Maybe it would be better if I can send you the images step by step. I cannot post it here, can I send you the email. You have an email ID. Let me know.