function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

New Toolkit - errors while creating projects

I'm thrilled to try out the new Toolkit!  I've survived the install, but unfortunately, I'm unable to successfully create a project.

I did a fresh Eclipse install, followed by a fresh Toolkit and WST install. 

I then tried to create my first new project, resulting in this error:

RuntimeException: Failed deployment: UNKNOWN_EXCEPTION msg:UNKNOWN_EXCEPTION: An unexpected error occured. Please include this ErrorId if you contact support: 1019309728-308

I then tried to create a new project for another SFDC org (this time a sandbox org), and project creation culminated in this error:

RuntimeException: Failed deployment: INVALID_CROSS_REFERENCE_KEY msg:INVALID_CROSS_REFERENCE_KEY: invalid cross reference id

I'm happy to share more details (which SFDC org, etc.) if someone wants to troubleshoot with me further.

Just a dash more troubleshooting info.

An Appirio colleague reported no difficulties in installing the new Toolkit and creating a project.  So I tried again, against two different SFDC production orgs - one UE, the other EE - and this time, it worked for both.

But, the original production org (which is EE) still fails with an UNKNOWN_EXCEPTION.

I should also add that in both failure scenarios (production EE and sandbox UE), I still get an Eclipse project, and the SFDC schema browser is functional.  But the "src" folder in both cases is nearly empty (just contains unpackaged\project.xml).

I don't know why the original production org failed, UNKNOWN_EXCEPTION is not easy to troubleshoot.

The folders for custom components will appear in the Eclipse package viewer once you have something to put in them. For example, if you create a custom object, you'll get a folder for custom objects, but only after you created it. What's in that original EE org that failed?

FWIW, I use a DE org for testing so that I don't have to meet the testing requirements.
Thanks Mario, I can see how the folder structure ought to look for a successfully created project.  There are definitely s-controls, custom objects, and the like in the EE org that's failing to create a project.
If you can send me your log, I can have someone look at why it's failing.


Please do NOT send login credentials to me or anyone. But you knew that.
Glen - We've determine the problem and have a resolution.  We're currently going through the testing process.  The fix will be available most likely in the next couple days.
Glen - We've determine the problem and have a resolution.  We're currently going through the testing process.  The fix will be available most likely in the next couple days.  (No toolkit update necessary.)
Sorry for rushing you, but... Any updates?
Hey everyone.  Sorry for the late notice, but the release has been delayed until mid-week.  Look for a posting on these message boards.

To rollback to an earlier version, move features/com.salesforce.toolkit.* and plugins/com.salesforce.toolkit.* to an archive location and re-install the previous version from the following update site:

Sorry for the inconvenience.  Please email me if you have any questions or concerns.


Yuliana Di PierroYuliana Di Pierro
@MarioKorf can you please send me an email so I can contact you? I tried creating an account at and it says the user name I selected is already taken. When I tried to log in using by laptop, a verification code was sent to

It is very strange since my username would be my personal email address... 

I am trying to sort it out, but I think it might be related something we may have done at DF15 using the same computer?

Thanks for your help