+ Start a Discussion

Serious Issue with SFDC production trigger

Dear all,
I have very critical issue with production trigger, as it not allowing me to inactivate it.
I've changed the corresponding meta xml under each trigger and tried to Deploy to Server thru eclipse, but it doesn't update in production!!! :-( This is very very critical,as i need to disable the trigger very soon now. Please help me what could be the solution to edit/inactivate the trigger?

<?xml version="1.0" encoding="UTF-8"?>

<ApexTrigger xmlns="http://soap.sforce.com/2006/04/metadata">





Thanks in advance


The only way I know to do it is to comment out the code and deploy it again.  It will still be active, but won't do anything.  I still say this is a big problem with production, no way to deactivate a trigger.


Dear Mark,

thanks for the immediate response! :-)

Actually, we tried to update the meta xml and changed the <Status>element value to Inactive from Active and that doesn't help even after Deploy to Server from eclipse.

 Then we modifed the trigger and right click under unpackaged directory and select Force.com->Save to server and then did Deploy to Server. but i shocked server doesn't accept our modification and still showing the previous code what was there already! But it worked perfectly, when i tried from sandbox environment. This is really weird.  Even if we comment out the code trigger and do Deploy to server, would this prodction server accept it?

Thanks again Mark.


Please Simon or some expert You people has to give us the solution as we are suffering a lot !  


Yep, comment out the code in the trigger and then Deploy to Server.  That's the only way I know.  Saving doesn't work, editing the xml doesn't work, deploying an inactive trigger doesn't work, can't edit in production...problem.

The commented code is not getting reflected when i seen from GUI even after deployement from eclipse. Still showing the last modified date as the old date.
The trigger showing the old code only even after i deploy to Server thru Eclipse Force.com->Deploy To Server by right click on the entire package! :-(
I think this is ridiculous .. i wonder why SFDC doesn't have the feature to enable it?
Please consider this as a very very critical issue.
Still, I believe there would be some resolution from SFDC admin/experts.
Kaja, I've had this exact problem several times -- do you have unit tests that depend on that trigger being enabled?  Eclipse stops reporting test failures sometimes when a lot of files are going up at the same time, which is what it's always trying to do on production.

Set a debug log on yourself in Setup -> Monitoring -> Debug Logs.  If I'm wrong you will see a successful Run All Tests including whatever edits you're trying to make.  If I'm not, you'll get the line number where it's failing.

Usually all of this stuff goes away if you start a new workspace -- close Eclipse, re-open, make sure it's an empty directory.  Re-download the /src/unpackaged from the production org, and then do what Mark's saying.   Maybe try support too?