function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion IDE v3.3 and INVALID_LOGIN error

I’m new to Apex. I did a fresh install of IDE v3.3 and followed the Quickstart example online to get me going. In the New Project wizard, I selected > Project and clicked ‘Next’. Fro my login credentials I entered the username and password that I use to log on to the Developer Edition; by default the “SOAP endpoint” points to the Developer Edition:


Can someone explain why I’m getting this error?


ToolkitConnectionException: INVALID_LOGIN: Invalid username, password, security token; or user locked out.


Thanks in advance!

Basically, you need to append your security token to the password in the password field, because you're not connecting from a "trusted" address.
This goes for all API based connections, i.e. everything connecting to SFDC except when you do it manually via

While in the UI, go to Setup >> My Personal Information >> Reset My Security Token and click the button. The token will be delivered via email.
Append the token in the email to your password in the Toolkit and you should be good to go.

Alternatively, you can add your IP address to the list of trusted IP addresses under Setup >> Security Controls >> Network Access. To disable this behaviour alltogether, you could put in to as valid IP address range, but I wouldn't recommend it.


I did append the token after my password but I still get the message shown below. Any suggestions?


           Unable to finalize project creation.  Double-check your connection
           settings.  You may adjust the settings and re-sync on the project
           properties page.

           ToolkitConnectionException: INVALID_LOGIN: Invalid username, password,
           security token; or user locked out.


You'll get temporarily locked out if you try to login too many times and fail.

Is this issue still persisting?

You may want to reset your security token one more time.
even i reset the security token i am getting the same error
I've reset my security token yet another time but the problem still persists.
Just give password as password and security token as security token.if u give  security token wrong or password wrong ur security token was expired and u give another time rest security token that was in developer edition .
Did you put your security token to here?