function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
MarkL.ax269MarkL.ax269 IDE synchronize issues - "invalid thread access"

I'm trying to move to the new IDE and get everything in sync, but I've got a lot of "blue arrow" sync issues in my sandbox. Most of them are within referenced packages or installed applications. Opening the components in the compare editor shows they are exactly the same, so I'm not sure why I'm getting the sync error in the first place. I want to copy everything from the server to local to get it in sync, but syncing results in two issues.

1) If I try to Apply Server to Project on a referenced package, I get the "invalid thread access" message.

2) If I try to Apply Server to Project on an installed application component or unpackaged components like scontrols, it looks like it completes successfully. However it is not removed from the synchronize perspective and will appear again the next time.

Hard to say what's going on here, but I will forward to our team and see if the invalid thread access rings a bell.
Hey Mark.

You've raised a few known issues, but the core issue is that "Synchronize from Server" is not intended to support synchronizing installed, managed packages ("Referenced Packages").  This will be resolved in the next patch release (after our upcoming release).  In the meantime, please use "Refresh from Server" to fetch updated or new installed, managed packages and their content.

Another option, albeit less convenient, is to recreate your project.

Sorry for the inconvenience.

Thanks Chris.  I tried Refresh from Server on the one referenced package I have installed and I get an error that says "Salesforce Recruiting is not IDEmanaged resource."  The spacing is exactly what's in the error.  So I tried it for the entire project and after crunching for a couple minutes, the "Operation in progress" box just went away.  On looking at the sync perspective again, the list is still the same.

So I tried it on a single unmanaged, unpackaged scontrol - onesI had written months ago but it was insisting was out of sync.  The progress box almost wasn't there, it disappeared so fast.  Checking sync again, and it's still listed with a blue arrow.

Finally (because it wasn't a big deal) I created a new workspace and a new project.  As soon as the project was created, I immediately tried Synchronize with Server and the exact same list of components were listed with blue arrows, including my own unpackaged, unmanaged scontrols.  How could they be out of sync if I just created the project from the server?

I'm sorry if this is known and is fixed in the next patch, but I thought you would like to know what I'm seeing.  Thanks again for all the hard work.

Anyone have an idea on this sync issue?  Anyone able to replicate it?  This causes me a big problem when the time comes to deploy.  I have no idea what it would do to my production org if I just told it to sync everything and I'm not about to find out.  Meanwhile, selectively deploying doesn't work either because it tries to validate everything...even triggers/classes I have not selected and have not written test methods, which completely stops deployment in its tracks.

Now I'm completely stuck.  I may go back to the old toolkit.

Hey Mark.

A few things here:

1.) In the upcoming patch release, the synchronize feature will exclude installed, managed packages (or "Referenced Packages") from consideration.  Instead, "Refresh from Server" should be used to update installed, managed package content.

2.) In the upcoming patch release, we resolved the following deployment issues:
a.) When deploying to a non-Production org, tests are executed.  Only Production deployment will execute org-specific tests.
b.) Installed, managed packages tests were executed.  These tests will be excluded.

3.) We'll look into the issue about synchronizing a new project shows components in conflict.

4.) We'll look into the issue about the synchronize view not removing applied content.

The upcoming patch release will be available at or just after the end of the month.  In the meantime, can you send me your logs ($workspace/.metadata/.plugins/com.salesforce.toolkit/force-toolkit.log) that contain statements for the following issues:
a.) "...not a... managed resource" after "Refresh..."
b.) #3 above
c.) #4 above

Thanks for your patience.