function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

"AppExchange Package not found" after registration

I am trying to install a new version of my app that I have uploaded and registered on Appexchange. It had no problem with upload and registration. However, when I try to install the app, I get the message:
AppExchange Package not found
The AppExchange package with ID 00D3000000078nY00530000000wqik could not be found. It may have been deleted by the owner. If you are installing this from a public AppExchange listing, please report this missing package to If you are trying to install a privately shared package, please contact the package owner directly to resolve.
If anyone wants to see this problem themselves, try installing:
It does not have a password.

Please let me know if it works for you (and uninstall it if it does).
I would appreciate any way to get around this problem.

P.S. I have also logged a case on this problem, but hope someone has an expedient work around.

Message Edited by RichardC on 04-26-2007 10:13 AM

The problem just went away. Disregard this issue for now.
ABSI (Benny)ABSI (Benny)

Hello Richard,

How did you solve your problem.

I have build a package in a devl account, registered and published.

when I want to install in a live org I got the same error message

AppExchange Package not found

The AppExchange package with ID .....

When I try to install it in another devl account it works

Thanks for your help





Hello Benny,

I did nothing to solve the problem. The installation worked in a client account. When I went tried it again in my test account, it worked. I suspected that Appexchange released a fix, but apparently it doesn't work in all cases.
I've encountered the same case. I'm afraid that it occurs when the package-installing org is located in different instance from that of the package-uploaded org (e.g. na1 and na4).

In my case, waiting a few minutes after the upload enables me to install the package even in different instance.

This is most likely a result of replication.  Packages are uploaded first into the instance of the DE org you submitted the package from (for instance NA3), and then are replicated to the other instances.  So if you were to try to install the package into an org in a different instance (for example NA1) right away there is a chance you may do this before the replication is complete.  If you wait and try again the problem should not occur again.