function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Error loading paramete: sfdc.password of type: java.lang.String

I am trying to use the command line interface for Apex Data Loader 15.0.  I am receiving the above error.


Here is my process-conf.xml file


<bean id="csvAccountExtractProcess"
   <description>csvAccountExtract job gets account info from salesforce and saves info into a       CSV file."</description>
      <property name="name" value="csvAccountExtract"/>
      <property name="configOverrideMap">
         <entry key="sfdc.debugMessages" value="false"/>
         <entry key="sfdc.endpoint" value=""/>
         <entry key="sfdc.username" value=""/>
                <!-- password below has been encrypted using key file, therefore it will not work without the key setting: process.encrypt -->
         <entry key="sfdc.password" value="7e2dd57498ca6eca83040dbfedaa7900904863e5500fd6ab3aace7c94944482a97fa41fee9313237"/>
         <entry key="process.encryptionKeyFile" value="C:\key.txt"/>
         <entry key="sfdc.timeoutSecs" value="600"/>
         <entry key="sfdc.loadBatchSize" value="200"/>
         <entry key="sfdc.entity" value="Account"/>
         <entry key="sfdc.extractionRequestSize" value="500"/>
         <entry key="sfdc.extractionSOQL" value="Select Id, Name, ParentId, AccountNumber, AnnualRevenue, CHESS_Id__c, CHESS_PARENT__c FROM Account"/>
         <entry key="process.operation" value="extract"/>
         <entry key="dataAccess.type" value="csvWrite"/>
         <entry key="" value="C:\extract.csv"/>


Am I missing something?


If you need more info, let me know.  




Best Answer chosen by Admin (Salesforce Developers) 

I commented out the line


 <!--entry key="process.encryptionKeyFile" value="C:\key.txt"/-->


and now it works!

All Answers


I commented out the line


 <!--entry key="process.encryptionKeyFile" value="C:\key.txt"/-->


and now it works!

This was selected as the best answer

It didn't work for me . Any other thoughts?

rahul kumar(mumbai)rahul kumar(mumbai)

2013-02-17 02:41:48,453 INFO  [MerchandiseInsert] progress.NihilistProgressAdap
er doneSuccess ( - The operation has fully comp
There were 1 successful inserts and 0 errors.
you  willl get message like this as  shown above
This error will come when the password is not Decrypted by Soap
Step 1: encrypt -g <any text> like encrypt -g test
and then save in the process-config location with key.txt
Step 2: encrypt  -e  <password with security token>   "the location of key.txt"
and then save the value  in password.txt in the same location where you have saved key.txt
Step 3: make the .sdl mapping file.
    step 3.1 generate the .csv file as per operation performed (insert, update, delete).
Step 4 make the process-config file
Step 5 run the command from bin location of data loader as
process.bat <process-config location>