function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

554 Transaction failed - Issue with SPF?

We are trying to send an email to SFDC for parsing using the EmailToApex class example in the tutorial. Nothing gets posted. We looked at the other discussion threads and found some inference that the sender of the email needed to be the same as the account login on SFDC. Not sure why that would be but we tried it anyway - no deal.

We activated bounce back on the messages and got a response that says the following:

554 Transaction failed: No authentication check passed.

Return-Path: <>

X-SFDC-Interface: external

In looking at the hint for the Advanced Email Security Settings, it says the following:
Before enabling this option, make sure that your users email domains support at least one of the following protocols: SPF, Sender ID, or DomainKeys.

In looking at the rejection (bounce back) response, it appeared that could in fact be the case.
(Note the NONE next to each of these values).

We contacted our mail host and they have activated SPF for us on our mail server.
However, they said that they will likely need to add the SFDC mail servers to our SPF service as well.
Is that true?

Here is the language from the hosting company support rep:
Tech Support: Ask SalesForce "What do I put in my SPF record to make sure messages sent from the SalesForce server pass SPF checks?" If SalesForce publishes their own SPF record (which I'm sure they do) they will tell you something like "include:(some server here)". This will be the most accurate way to ensure that we setup your SPF record correctly.

Do we really need to have SFDC servers on our mail sever? That seems unnecessary. If it is in fact the case- what are the SFDC mail servers we need to add? There must be several.

Any help is appreciated.

I'm getting the same error...did you ever get this problem resolved?

Did anyone find a solution for this?


I'm using google apps for my email and am getting this message.


Well...  I just found an answer for this.


If I turn "Advanced Email Security Settings" off in the particular Email Service, the emails come through fine.