function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Anyone getting unknown exception errors running tests via Eclipse after sandbox upgrade?

After getting all my tests running fine on Friday, I came in this morning to re-run after some changes to Apex classes. The sandbox was upgraded to Spring 09 on the weekend, and now every time I try to run any tests via Eclipse I get the nice "unknown exception" - unexpected error has occurred message.


I can run tests ok via the browser but this is not ideal for debugging.


Anyone else getting this after the Spring 09 upgrade? I am still coding using v14 of the API.







Can you please open a case with Support?  The error message returned from the server and displayed in the IDE most likely contained an identifier they can use to track down the problem on the server.



Jon Product Manager

Just an FYI that I'm hitting errors as well and did submit a case.  If anyone finds a solution that can be implemented without the assistance of Support, please post it.  I haven't tried yet, but suspect this error is going to prevent me from deploying to production, which I need to do soon.

Hey Jessie - I also raised a case, and support apparently released a patch last week. However to get my Eclipse to work, I had to go into the project options in Eclipse, change the Apex debug settings (eg. from debug -> fine), Apply and then go and run tests. This worked ok for me, and I could then change the debug settings back again.


Note this is not the Apex debug settings on the 'run tests' panel at the bottom of Eclipse; it's the project-wide settings (right click on the project, then Properties, then, then Apex Code).


Hope this helps,