function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

No Deployable Components Found

In Eclipse, I right click on a project and select's Deploy to Server... option.  It pops up an exception saying "Unable to deploy - no deployable resources found."


How do you resolve this? 



What, if any, files are in your project?



Are there any exceptions in the IDE log?


What OS, Eclipse, and IDE version are you using?



Also, exactly when does this message occur?  Is it after your enter your credentials for the target organization in the Deploy to Server wizard?  If so, are you certain you're using Admin credentials?

Scenario:  It currently syncs with a dev instance without a problem.  I want to move it to another instance.  I thought this was a way to do that. 


Suspecting that maybe I need to change the login and then do this, I just tried that.  But, even after changing to point to a different dev instance, it gives the same error.  


Can someone please detail the exact steps to use this to push your objects and code to another instance?

The steps to deploy are:

1. Launch the new project wizard

2. Enter your credentials, select the components to download, finish

3. Once your project is created and files are downloaded, right-click on your project and select > Deploy to Server

4. Enter your credentials, selet the components to deploy, finish


It's pretty simple, so either there's something obvious we're both missing, or you've found a bug.  The more detail you can provide about what you're doing and seeing in the IDE, the faster we can get to the bottom of this.



Jon Product Manager


Hi John,


I am faching the same error. I amtrying to reflect some of the contents in production enviornment to the developer environment and I cannot do that from the production enviornment


I have also followed all the steps you have mentioned. Please look at the issue and tell me if there is any restriction.





Atif MohammedAtif Mohammed

I have imported the war files  into eclipse but unable to deploy to server.

giving me an error like"Unable to deploy-no deployable resources found"