+ Start a Discussion

Syntax coloring

Is there somewhere where I can check how my Eclipse editor handles Force.com syntax coloring?  None of the syntax coloring is shown, everything is black.  I've tried changing the customizable Java syntax coloring, which has no effect.


I'm running Eclipse 3.4.2 on XP Pro with SP 3, if any of that makes a difference.




I don't see anything specific inside of the Force settings in Eclispe.


I would say make sure that you are opening your apex code with the Apex Code Editor (because that affects Syntax coloring).


You can double check this by right clicking on a file and selecting "Open With", this will tell you what the default editor for that file type is.




It says I'm opening with the Default Editor...I assume that's wrong?  I tried opening with Java Editor, which gave syntax coloring that is defined in the software, but not the Apex syntax coloring.  There is no Apex Code Editor on my list (internal or external editors).  Do I need to import the text editor or something?



Two questions (please don't take offense)


1. Are you sure you have have the Force IDE add on installed?


2. If you do, are you sure are you in the Force perspective?






Yes to both...in the Other list of editors, "Force.com Start Page" shows, but that's not what I'm looking for.  It's like the Apex editor was never installed when I downloaded the IDE...

Hrm that is whacky.


I tried using 3.4 with the newest Force but it was giving me problems with stuff so I went back to using 3.3 with the newest Force and it seems fine.




I'm having the exact same issue with S-controls. 

I do see that I am opening the file in the "Force.com HTML-based Editor"


I do get some coloration.  The tags are colored. None of the javascript in the S-control is colored though.  Classes and components (mostly made up of tags) are also colored properly.  


I'm running 3.4.2 64 bit on Windows 7 64 bit.  It doesn't appear that Europa has a 64 bit for Windows, so I'd really prefer not to have to go back.


Actually, I just figured it out.


The Europa instructions tell you to download the WST tools from the Europa discovery site.  I  went into the Ganymede discovery site and installed: JavaScript Developer Tools, Web Developer Tools and WST Common UI.


I restarted Eclipse and poof, my S-controls are in living color again.


I'm not sure which one(s) you actually NEED.  But this worked for me.



e r i c.ax249e r i c.ax249
I only installed "Javascript Developer Tools" and "Web Developer Tools" and got the highlighting back for javascript.  Thanks Barry.

Hi eric and BarryPlum,


I had this problem and followed your directions and it worked.


I just went to the Menu option:

Help > Software Updates... > Available Software


And looked for and Installed the following packages:

Ganymede Update Site > Javascript Developer Tools

Ganymede Update Site > Web Developer Tools


After that, I got the Javascript code highlight as I needed.


Thanks guys,