function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Hyperlink Formula gets cut off when executed

Hello everyone need some help with a Hyperlink formula.  I've created a hyperlink and when I "Copy Link" and paste the link works fine.  However when I click on the link in my account it opens a new page but only puts part of the URL.  If I try to paste the URL that I copied it works as well, just not when I click the hyperlink in my account.  Any suggestions?


Here is the URL (Note the *'s are numbers removed for security purposes):****7&extension=*****&number=423***505&username=lsdwareh&password=wt1&calleridname=johns&success_redir=


When the new page opens this is the url it opens to:****7&extension=*****&number=423***505&username=lsdwareh&password=wt1&calleridname=johns&success_redir=


Note it is cutting off the****7&extension=*****&number=423***505&username=lsdwareh&password=wt1&calleridname=johns&success_redir=




Oh what difference one character makes...


It should end in &retURL=%2Fa0DU000000A0WBg


Thanks xphiberoptikx,


I tried adding the %2f as you suggested but it still isn't working and still cuts off.  Any other suggestions?****7&extension=*****&number=423***505&username=lsdwareh&password=wt1&calleridname=johns&success_redir=



It is still cutting off at the &retURL=%2Fa0DU000000A0WBg


You used a / instead of a %.


That is the odd part I used a % but it is showing as an /.  I've attached a screenshot below.



What is the point of the + and " usage vs. just using & to bind the pieces of the URL together? Some how your URL is converting %2F"+Id+" into /Id.



No point really.. I am new to this and that was how it was recommeneded.  I am certainly open to other suggestions.  Can you give me an example of how you would recommend doing this?


Thanks for the help I appreciate it!


Quick question... are you asteriks representing a one for one of the actual missing characters? For example are there 4 characters between 1 and 7 as you have 4 asteriks?


Reason I ask is because as the URL sits right now there are 235 characters. Text limits to 255. If the asteriks make up enough characters to go over that limit, it would explain the truncation issue.


I changed the settings for my Server_ID and Username to allow for more characters. That makes the standard URL 250 characters.  Even after making that change it is still turnacating at the same point.  




Check PMs




use & inplace of + symbol


The last piece "&retURL =%2F" &id,""


We already tried that...

Bdogg - any updates on a solution?


No updates yet, I worked with Support and they were unable to help me with it. They have escelated the case to a Teir2 Support rep.  I have a call with them today.  I'll let you know if they come up with any other resolutions.


I spoke with Support, and they beleive that our phone system "Fonality" when they are redirecting is taking the giving the URL to the browser and not Salesforce, and they said they think that the "&" in the URL is being terminated as they (Fonality) do not recognize it. 


Any suggestions on how to get rid of the "&" in the url? The URL is referencing another object in SF.