+ Start a Discussion


We implemented an approval workflow and also approval escalation when initial approver did not respond within 24 hour. However, when we tried to UPDATE the ACTORID for the processinstanceworkitem, we received this error:




what permission do we need for the user to be able to update the processinstanceworkitem?





Hi, this error usually means that one of the id's in your data that references another entity (i.e. a lookup field) has invalid data in it. So for example it could be that the entity you are trying to reference doesn't exist.

Thanks asadim for your response.


When I search on SFDC reference, I found this info:



An operation affects an object that is cross-referenced by the specified object, but the logged-in user does not have sufficient permissions on the cross-referenced object. For example, if the logged in user attempts to modify an account record, that user might not have permission to approve, reject, or reassign a ProcessInstanceWorkitem that is submitted after that action.


So I thought that it is related with permission access. And I double check on the Id of the object we tried to change, which is ProcessInstanceWorkItem, and it is there. Any other possible cause of this error?



Would you be willing to share your code for how you updated the ActorID on this approval?  I'm trying to do the same thing and can't seem to get it to work.

Did you get it working? I mean reassignment of  Approval process

Sowjanya Bitra 9Sowjanya Bitra 9
I Am also facing the same issue when trying to reassign a record in approval process. Did anybody find the solution for this?