function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

How to call out an (SFDC) Apex webservice from Oracle SOA Suite?



Does anybody have an example of how to do that? I mean, the problem is that it seems "Oracle SOA Suite" doesn't allow to process the WSDL of external webservices by its file, only by giving a valid URL address where the webservice is located.


For example:   or


The problem with Salesforce is that the generated WSDLis not public from an URL address.


Please, help in this case.







Did you get this working?   I need to do the exact same thing.   Would you be willing to share a sample of your code?




Hi Alan,


Unfortunately, no yet.


Anyway, as soon as I could get this working I'll let you know. Meanwhile, we had to use other kind of web servers to make this integration possible.





Shailendra SuryawanshiShailendra Suryawanshi

Download the partner/enterprise wsdl from SFDC & invoke "login" action using Fusion.


As mentioned in above reply , You need to have 2 wsdls :

1. Enterprise WSDL to make Login() call which will return Session Id(Note : You need to pass SFDC User Name , Password and Token generated by SFDC).

2. You need to have WSDL for the custom functionality developed on SFDC(APEX Webservice).


you can use Salesforce site feature. Just enable your partner wsdl on your side so that you can access it from outside world

Shailendra SuryawanshiShailendra Suryawanshi


I'm working on a POC for integrating Sales Force with OFMW. I've downloaded partner.wsdl/enterprise.wsdl from Sales Force, imported it in Fusion & now when I'm trying to invoke SF login() action from Oracle Fusion with valid user name & password along with security token, I'm getting below error. Can anyone help me to crack this??? I tried importing the same wsdl in Soap UI & there it's working fine.

Getting below error:

summary=<summary>oracle.fabric.common.FabricInvocationException: Unable to access the following endpoint(s): htps://</summary>,detail=<detail>Unable to access the following endpoint(s):</detail>,code=<code>null</code>}

Not fatal connection error ... not retrying.

I tried both enterprise.wsdl & partner.wsdl but getting same error

Please suggest.


From error, system is not allowing to call salesforce server. Please check your network setting.

Shailendra SuryawanshiShailendra Suryawanshi

 I tried importing the same wsdl in Soap UI & there it's working fine. It's failing only from Oracle Fusion.


I even tried writing a Java program & it's working fine.


Any guesses??


Shailendra did you get this working? Pease advise.