function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

No Debug Logs, when running unit tests in the IDE

I just installed the Version: Winter '11 (20.0.0) plug-in this morning.

Now I can't see and debug logs when running Unit Tests. The window in the bottom right only contains "No Debug Logs"


The debog log does show up when running in the browser.


My other developers are having this same problem. Is there a setting I'm missing? Has anyone else experienced this?




I noticed the same thing myself.  Hopefully, there will be a patch, or instructions on how to address this out soon.


Are you guys still using Galileo? I'm wondering if updating to Helios would help...



I am.  Galileo is the version that the standalone installation was bundled with.


Using Eclipse Ganymede


It's not Eclipse... it's this version of the IDE.


Running the IDE as a standalone I still get "No Debug Logs" in the log output.  So currently the only way to view debug logs is through the UI.



Our IDE team is aware of this issue and is working on a fix.  No ETA at this time.  In the meantime, running tests through the browser is the best workaround we can offer.


We appreciate your patience as we work to resolve this.



Naaman - Tier 3 Support


I went straight from IDE 19.0 to 20.0.1 on Nov 19th after I read that 20.0.1 had been released and included the log fix.  However, on a Mac, when I right click on the specific test class and run, I still get No Debug Logs.  When I run tests by right-clicking the classes folder, the same happens.


On a PC with IDE 20.0.1, I am getting a debug log when I right click the specific test class and run.


Mac: OS X Snow Leopard, Eclipse Galileo 32-bit 20100218.1602

PC: Windows 7 64bit, Eclipse Galileo 32-bit 20100218.1602


I can confirm version 20.0.1 shows the debug logs running Windows. Thanks for checking on that!

I just installed Eclipse 3.6.1 Helios 64-bit on my Mac and the debug log is working now.