function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Custom setting limit was reached

I use custom setting in my application.  I currently hav 6 defined.  In test code I insert or update the custom setting to test the behavior based on how these setting are set.


I deployed my code to an org where i package the application and now all my tests that attempt to set the custom setting are failing with the following error.


This just started last night - has something changed at Salesforce.


6:28:56.968|FATAL_ERROR|System.DmlException: Insert failed. First exception on row 0; first error: UNKNOWN_EXCEPTION, The custom setting organization limit was reached: []


        Organization_Settings__c orgSetting = Organization_Settings__c.getInstance();
        System.debug('orgSetting ' + orgSetting);
        if (orgSetting != null){
              //override partial shipments setting for test
              //set partial shipments for test
              System.debug('partial ' + partial);
              orgSetting.Partial_Shipments__c = partial;
              update orgSetting;
        } else {
            insert new Organization_Settings__c(Partial_Shipments__c = partial);


I tried setting the custom setting in the SF UI and get the same error.