function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
pinalpinal IDE error - cannot install the IDE

Hi Folks,


When I try to install the IDE, I get the following error. I have the latest version of IDE and Java JRE 6 version.


JVM Terminated. ExitCode = -1


Please provide your thoughts!


Thanks in advance!




I made the following change and it worked!


Append  "-vmargs -Xms256m" to the Force.ide shortcut in the Target text box (right click, properties)


Thanks Pinal!  That worked for me as well.


Pinal - you are my hero.  After going round and round on this, you suggestion works!  Thank you.....


Brilliant! Worked for me as well. Thanks!

Seems like this is something that needs to be addressed.   I installed a clean version of the standalone IDE, and a fresh install of Java 1.6 on both Win7-64 and WinXP-32. Happened both times.


Glad to help as much as I can!


I appended the string to the shortcut target so it looks like


"C:\Program Files\\ IDE\forceide.exe -vmargs -Xms256m"


But when I try to click on "Apply", I get a message "The name specified in the target box is not valid".  What am I doing wrong?


Try putting the parameters after the path.  Like this:

"C:\Program Files\\ IDE\forceide.exe" -vmargs -Xms256m