function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Michael RamczykMichael Ramczyk 

Informatica Connectivity

I am having some issues connecting to our prod sfdc org.


I can connec to our sandbox from our dev infa server.  I then try to connect to the prod ord from our prod infa server and am getting the following error:

SFDC_31101 : [FATAL] Login failed.  User [].  Fault code [32].  Reason [SOAP Error : [Version Error : Version Mismatch]. Please Contact Informatica Customer support.].


I am using the same service url:


in test where it works i am using


Is this that the prod server might have a proxy issue?

Michael RamczykMichael Ramczyk

Anyone seen this before or had this type of issue?


Yes, I get this error when connected to Prod SFDC every once in a while.  Have never gotten it in Dev.  By 'every once in a while' I mean about once every 3 or four months, and we run our cycle daily.  Therefore, it is very intermittent for me, no way that I can every recreate the error for troubleshooting purposes.  It is one of a couple of errors that we get that we 'just live with'.  The error says 'Please contact Informatica Customer Support.' but they have nothing to say about it, they tell me to contact SFDC, and SFDC tells me to contact Informatica.  So, nothing happens, which is why we just live with it.


I will not that recently the error changed it's verbiage used to say 'Version Mismatch', just like yours, but lately it says 'Tag Error : MisMatch'.  I assume they are the same error, but they could have different causes/meaning.  Hard to say as I never get any assistance on them.  Here's my full error message(just received this morning)...



: [FATAL] A fault is received in an update request. Fault code [3]. Fault subcode []. Reason [SOAP Error : [Tag Error : MisMatch]. Please Contact Informatica Customer support.]. Detail [].




I am also getting the Same error When I am creating records in SFDC using Informatica.If you have solution for this Please let me know.Bellow is the error I received from SFDC.


[FATAL] A fault is received in a create request.  Fault code [3].  Fault subcode [].  Reason [SOAP Error : [Tag Error : MisMatch]. Please Contact Informatica Customer support.].  Detail []


Thanks in Advance

Murali Aitha



I'm still getting the same error.  In fact, I just got hit by one this morning, right after you, Zamie, commented on this post.  One thing I had tried to do was update the API version that were using to connect to SFDC.  We were on 14.0 and I updated to 19.0 about two weeks ago.  I was hopeful this could have something to do with it.  We needed to do this anyway.  I'm sad to see this has not made a difference.  At least I know this was not the issue now.  I really have no further ideas as to what to try.  Here's my latest error message:


Severity Timestamp Node Thread Message Code Message
ERROR 2/3/2012 1:55:35 AM PC_Prod_Node01 READER_1_1_1 SFDC_31103 [FATAL] QueryMore failed.  User [<user removed>].  SOSQL [<query removed>].  Query Batch Index [6].  Fault code [3].  Reason [SOAP Error : [Tag Error : MisMatch]. Please Contact Informatica Customer support.].
ERROR 2/3/2012 1:55:35 AM PC_Prod_Node01 READER_1_1_1 SDKS_38200 Partition-level [<SQ removed>]: Plug-in #310600 failed in run().


Hi, I wanted to provide a little more information from the Informatica Knowledge Base.  Article #123312 states this:


"Reason [SOAP Error : [Tag Error : MisMatch]. Please Contact Informatica Customer support.]" when PowerExchange for 9.0.1 HotFix 2 session with Salesforce target fails
Problem Description

A PowerExchange for Salesforce 9.0.1 HotFix 2 session, with Salesforce target, fails with the following error:

[FATAL] Query failed.  SOQL [SELECT Id FROM Affiliation_vod__c WHERE External_Id_vod__c = '001A000000RRuhFIAT:null:001F000000f5M5IIAU:null:Head of Nursing'].  Fault code [3].  Reason [SOAP Error : [Tag Error : MisMatch]. Please Contact Informatica Customer support.].

This issue occurs when large files are loaded.

This is a known issue (CR 270161), which has been resolved in PowerCenter 8.6.1 HotFix 14. To resolve this issue, upgrade to PowerCenter 8.6.1 HotFix 14.

More Information 
This is a intermittent issue that occurs when large files are loaded.
Applies To 

Product: PowerExchange for 9.0.1
Last Modified Date: 10/10/2011 10:09 PM  ID: 123312


We are on 9.0.1 HotFix 2 ourselves and we're not going to GO BACK to 8.6.1.  That just seems odd to me that they would even call that an 'upgrade' and suggest that we do that. 

Shri RajShri Raj

Im facing the same problem. Any solutions so far ?