function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

No class coverage is displayed in Apex Test Runner tab in Eclipse

Hi everyone,


Today I faced with one issue related to displaying test coverage in Apex Test Runner tab in IDE. It worked today but after PC reboot it stoped.

Actually it is working in interesting maner. It shows TRIGGERs coverage but not CLASSes. It was showing today class coverage but now it isn't. I just downloaded Windowse's updates and reboot my PC. No changes in Salesforce environment or IDE.

If I run the same test class from browser it shows classes coverage as ussual.

What can be the problem?


Update: I just tested run test on other's developer PC and there is the same situation - no class coverage.


Update 2: if I click Run Tests on classes folder it shows me apex classes code coverage. If I click Run Tests on ONE particular class then no. But yesterday it showed my code coverage for classes if I click Run Tests on one particular class. What is going on?


Not solved but...

Now I'm working with another project and there is everything OK. But at the same time on previous project is no class coverage.



I'm experiencing the same issue. I cannot see my test coverage in Eclipse Test Runner for triggers.


However I can see the coverage for the triggers and classes in the Salesforce Code Coverage interface.


Has anyone come across a solution to this? I have the problem also and it's a pain to switch over to the UI all the time.


As for me - no :(

But I have this problem only in one environment. In others all works perfect.

Maybe if you can re-create this particular environment it will help.


Interesting - I see the problem in all environments I've been working on with multple computers. Maybe I'll submit a case.


I am also having this problem.    With some of my projects I see the class coverage.  With my two large projects that have many triggers and hundreds of classes I do not see my class coverage.    This is a big problem.  Any ideas?


It's a pitty but no solution.

As for meI was moved to another environment and this problem doesn't appear in this new environment.


As a solution you can try to create new dev environment instead of current.


There is a Winter 12 IDE update for eclipse. This should resolve the issue. If not, the other option from what i'm hearing is to place the test scripts inside of your trigger/classes. Try those, and good luck.


Oh yes! I totaly forgot that I'm using the very last version.


TerryLuschen, try to download and install the latest IDE and run tests there. After this, pleas write to us what have you achieved.


Great idea, but it did not fix the problem for me.    It installed version 23.0.1.   I still only see the test coverage for Triggers.   The only class that shows up is my test class.


We keep our tests in separate classes and we will continue to need to do that.


Any other ideas?   Does this bug need to be posted somewhere?   Is there an API call I could run for this test and look to see if the response contains the needed information.  It would be nice to know if it is the Eclipse plug-in causing the problem or if the problem is the response data from Salesforce.



Great idea.   I installed version 23.0.1 and that did not help.   I am still just seeing the Trigger coverage in my results.  No class coverage except for the Test class itself.


Is there a place to post a bug like this.   We need to keep our tests in separate classes so I cannot go down that road.


Is there a way to test this with an API?  It would be nice to know if Salesforce is not returning the data or if the Eclipse plug-in is having a problem displaying the data.



Terry Luschen


All I can sugest to you is to use site to run tests...