function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Insufficient Privileges

Hi Guys,


I am using !actionRemote class from javascript and for this reason, I was getting "Insufficient Priviliges" on the relevant VF Page and I upgraded API version of the pages from 20.0 to 23.0 and it worked fine (irrelevant err message but version upgrade make sense here).


It was working fine until Friday and now the problem is, after the weekend the Production Environment gives me this error with 23.0 version but works fine in 20.0 version and the sandbox environments are giving me the error with 20.0 version but works fine in 23.0 version. I doubt this is due to the last upgrade of Salesforce during weekend, Has anyone every come across the same error.


Any reply would highly be appreciated!



Hi iffu,

I have not experienced such an issue , but in case the issue is coming after the upgrade one would suggest you write to salesforce at or create a case with salesforce in your org by providing all the details, in case if the discrepancy is due to the upgrade salesforce is the best authority to set the problem right.


Hope this helps.


Thanks Ispita for the reply, just opened a case to Salesforce, I will post the cause once I fix this, for other to benefit.