function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Content Search Via APEX not working in IE

I used the code snippets found in THIS POST and the search works for both Firefox and Chrome, but IE simply refreshes the page and a second press on the search button moves the user over to the Content Search page without the parameters in the Search box.


What is it with IE that would cause this behavior and how do I overcome it?


EDIT: This seems to be something with the way the browser is being forwarded. IE doesn't process the OUTPUT PANEL on the first button press. A second press does get this to work; however, the protocol and host have to be hard coded for IE to work - at least in my case.


So, the question becomes why doesn't IE process the outputpanel on the first button press?


Try using the full URL ie.


I had a similar problem trying to redirect to content detail page from a custom button.  The line in my buttons was;


window.location.href = "/sfc/#version/" + records[0].ContentDocumentId; 


That worked in chrome and FF but not in IE.  When I changed to the fully qualified URL it worked in IE.