function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

problem in inserting date field in web to lead

I have a web to lead web form where all other data is getting inserted but not the date field.

It is a date field not a date/time field and we are putting date in UK standard DD/MM/YYYY.


I also tried standard SFDC format that is YYYY-MM-DD, still it is facing the problem..what can be the possible issue ??



I have tried the same by taking the value on Date format as mm/dd/yyyy on web to lead form and this value is exactly display on the lead after creation. So I would suppest you to pass the date value as mm/dd/yyyy format.


Did this answer your question? If not, let me know what didn't work, or if so, please mark it solved. 


Web to lead supports a number of date formats, including both "European" and "American" date formats.




It is not working for the same format..


I'm facing the same problem..

I've created a custom date field, we're using it for both US and EMEA partners.
when a US partner fills out the form, the lead is created with the date field populated. But whenever a EMEA partner fills out, the lead is created with the date field blank.
Our Default locale (in the company profile) is "English (United States)".

Alberto AlaejosAlberto Alaejos
hi! I also have the same problem. I do not get date type fields in web-to-lead. Did someone solved the problem?
Marketing Department 14Marketing Department 14
I am having the same problem.

These are the lines in the form:

<input type="hidden" id="sf_Date_Received__c" class="w2linput hidden" name="Date_Received__c" value="2015-08-16" />
<input type="hidden" id="sf_Product_Group__c" class="w2linput hidden" name="Product_Group__c" value="Solar Power" />

Product_Group__c  goes into SF
Date_Received__c  stay  empty...
Steve Lam 3Steve Lam 3
Same problem.

Custom date field on the Lead object.
This format works: mm/dd/yyyy
But these do not: mm-dd-yyyy || yyyy-mm-dd
Talha SaqibTalha Saqib
Please try the following resource: