function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Where has my line by line coverage gone in Winter 14?

Hi guys,


Urgent issue here - I'm trying to build my test classes for a client app to deploy and I cannot see my code coverage. Yes, I know the coverage column has been removed from the setup page list, and I know that I have to open the Developer Console - run a test, then double click the test Run, then double slick the class to see the percentage.


When I open the class, and in the top left select the coverage from the drop down - it does not show line by line red/blue coverage despite saying that it has 57% coverage so far.


I ahve done this 7 times in chrome and firefox. No dice.


I am on CS17. EDIT: CS7


For now, you'll have to open up the developer console (hopefully you're familiar with it,) run the test class, and view the test results in order to see the red/blue highlighted code coverage that we're used to. 


It's seems like there's a big outcry from the developer community on moving the code coverage from the Apex class list view with a clickable link, to the developer console, so perhaps they'll move it back or show it in both places.


Thanks, but as I stated - this does not work.


See here:


Nevermind, just watched your video.


Open a ticket with Salesfoce? ;/


Edit: Another thought I just had is try creating a new dev org and running the test class there.


Oh man, that's what I was afraid of...


Is it just me, or is there no drop down options in there for bugs / technical issues in the open case view anymore?


Salesforce, you have systematically disenfranchised  the developers in your community by steadily removing all ability for them to find support from salesforce itself.


You cannot open a case from a sandbox - you cannot open a case from a developer org. We post on the developer forums and people answer - yes, but they can't fix bugs - and we're forced to open a case that we can't even categorize correctly!




Hi JayNic,

I have the same problem with the line by line code highlighting.

Have already tried to solve the problem with "Compile all classes",  with "Run all Tests". I created a new class, a new test class.

No chance. The red-blue background does not appear. 

It works just for a couple of classes and triggers. 

Unfortunately i have no solution for you. 

Can you post the Salesforce's feedback, suggestions etc? I will also open a case and keep you up to date.


I opened a case with them, and shortly afterward, the issue corrected itself. During this time, i didn't restart the browser or the pc.


The only thing I can think of is that at the time of the bug, I had only one TEST class that was covering this code, later as I kept developing, some other tests overlapped it and now there are two or three.


Maybe it's classes with only one test class that covers?


They jsut got back to me. He has said it's a known issue, and the dev team is working on a fix for it. He assumes it may have been deployed (since the issue fixed itself) or is in the process of deploying.


Hasn't happened again so far, but I have more tests to write this week. We'll see!


I can also confirm this behavior. I didn't modify anything, and the blue-red background of line by line code coverage appeares.

!!! BUT it did not worked for long. 

I opened the apex class in Salesforce directly. After saving this class, the line by line code coverage gone.



It is expected behaviour that after saving the class the test coverage is nullified. This is because it may or may nto have changed and the test is required to run again.


That being said, the SF Dev rep that contacted me yesterday said it was a known issue that was being worked on. So chances are it's getting ironed out as we speak

Fabien TaillonFabien Taillon

I had the issue a couple of times too, and cleaning the test history solved my problem.


Go to Setup / Develop / Apex Test Execution / View Test History and clear test results.


Then go back to Developer Console and try opening again your classes and running your tests, it should work.


You are the hero !  


Deleting Test History solved the problem.


Thanks a lot !!!

Kelly KKelly K
Had the same issue where I was working on testing my class out fully and my red/blue lines just stopped. Clearing out the stored test results resolved this.

They seriously have made the testing process as frustrating as possible...
John Reed 7John Reed 7
Also be sure to uncheck the Store Only Aggregated Code Coverage option.  It was checked by default in my sandbox.

User-added image