function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Outlook Edition - User permissions

I am an Admin trying to install Outlook Edition throughout my company and before I roll it out completely, I would like to clarify one aspect of the installation that I am having trouble with- the User Permissions tab and the changes I need to make to the O_Dictionary. 
According to the Advanced OE Admin tipsheet, I go to the User Permissions tab, select the modification options I want and then click Show File to open the settings file O_Dictionary.xml. Once I open this file, I see the following code:
   Note: The OverrideOptions value attribute determines whether the user is in restricted mode or not.
 <XOverrideOptions value="true">
  <CanModifySyncEntities value="false"/>
  <Sync entity="Contact" value="false"/>
  <Sync entity="Event" value="true"/>
  <Sync entity="Task" value="true"/>
  <CanModifySyncDirection value="false"/>
  <SyncDirection entity="Contact" value="Both"/>
  <SyncDirection entity="Event" value="Import"/>
  <SyncDirection entity="Task" value="Export"/>
  <CanModifyConflictResolution value="false"/>
 <OverrideOptions value="false"><CanModifySyncEntities value="true"/><CanModifySyncDirection value="true"/><CanModifyConflictResolution value="true"/><CustomTemplateClasses value=""/><Sync entity="Contact" value="false"/><SyncDirection entity="Contact" value="Both"/><ConflictResolution entity="Contact" value="Notify"/><SyncDirection entity="Event" value="Both"/><ConflictResolution entity="Event" value="Notify"/><SyncDirection entity="Task" value="Both"/><ConflictResolution entity="Task" value="Notify"/></OverrideOptions></Document>
When I followed the tipsheet instructions and changed the XOverrideOptions to OverrideOptions and saved the file, the User Permissions tab disappeared as expected. However, I went back into the file and put back the X to make the User Permissions tab reappear, and it did not. I ended up uninstalling and reinstalling the Outlook Edition because I did not know how else to make it reappear.
So, I am not sure if I followed the instructions properly, and I am not sure what exactly I need to change when the tipsheet says to 'Change the XOverrideOptions attribute to OverrideOptions'.  I would like to be able to adjust the User Permissions and bring back that tab. Anyone have any experience with this?
Also, what does the Restore button do, and is this how I can get the User Permissions tab back?
I tried to locate other resources and guides about the Outlook Edition, but was not successful. Any suggestions would be most welcome!


There are a couple of things that may be preventing the tab from appearing.  First off, because of the multiple types of things you are trying to do - might I suggest you contact customer support?  I seriously doubt that anyone in Tier 1 could help, so depending on their first response, I would suggest you ask to be escalated to Tier 2.

I'll suggest a couple of things to try or questions that might help you troubleshoot:

1. When modifying the O_Dictionary.xml file you need to make sure you're modifying the copy in the Program Files directory and not the one in the user's directory under Documents and Settings.  With that being said, if you do modify the O_Dictionary.xml file correctly in the Program Files directory and you are still experiencing problems then I would check the file in the user's directory under Documents and Settings to verify that it is being overriden correctly.

2. To get the user permissions tab to reappear - search for all occurrences of <OverrideOptions value="true"> and set it to false.

Let me know if this helps or feel free to update this topic with any additional questions.


Always ThinkinAlways Thinkin
In 3.2, has anyone been able to get the following triggers to function as described by the Tipsheet?

<PutRegistry name="ButtonStateSync" type="string" value="false"/>

<PutRegistry name="ButtonStateOptions" type="string" value="false"/>

<PutRegistry name="ButtonStateAssociations" type="string" value="false"/>

All 3 are supposed to remove the buttons for their respective actions. Similar modifications work for Mark for Sync and Unmark for Sync, but I could not get these 3 to work.

Always ThinkinAlways Thinkin
After a couple of restarts, the control to remove the Sync button works, but the others are still not functioning as expected.
Do you know if the PutRegistry command add AND edits registry entries?  Or does it only add new ones?  If it only adds, then do I need to use a .reg file for edits?

One Question team,


<SyncDirection entity="Event" value="Import" />


What does Import mean here? Is it syncing from Event in Salesforce to Notes or syncing Notes Event to Salesforce?


I mean "Export" and "Import" are relative to Salesforce or Notes?