function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Rachael BRachael B 

Adding emails to SF - Due Date doesn't fill in and record moves to bottom of activity list

Has anyone noticed that when adding e-mails from outlook to SalesForce sometimes it doesn't appear that the message was added? Upon further investigation however the e-mail was added into SF but was added without a due date.  This causes the e-mail to go at the bottom of the activity list instead of at the top where the most recient activities are logged.
I'm not seeing anywhere on the send and add page in Outlook where I can be sure the date is added and this only happens occasionally - normally a date is assigned to the activity automatically.
We are having the same problems. One of our theories is that it relates to the amount of time the email is open before sending. Has anyone found out the actual cause and a resolution to this? Thanks, Jeremy
Rachael BRachael B


We also think it has to do with the amount of time the email is open and goes into a draft form where the date gets "lost". suggested that we turn off Word as our default email editor b/c there is an issue with how Word handles the email depending on the status of it (new, draft, sent) however when this is turned off none of the grammer or spelling suggestions come up as you type and in order to at least check this before sending the email you have to be sure that the option is checked in your email settings.  The other suggestion they had was to send the email normal from Outlook then go back and select the "Add Email" option as the date stamp will always functions correctly however this makes for extra work.  Basically neither of the suggestions they provided work well for our company and I now have my deticated CSR looking into it further to see if it is a bug or an intergration issue but haven't heard back from her yet.

Thought I would throw the information back out there for you incase you would like to try either of their suggestions.  If I find out anything further on the issue I will also post it back out there for the community.

Rachel, Thanks for the heads up. We actually got a response from the SF tech crew as well. Their response "This is currently listed as a bug and our developers are working to resolve this with a future release of Outlook Edition". Hopefully, they can get it cleared up soon. Jeremy
Concenter  ServicesConcenter Services
Did you ever hear back from SF on whether this bug was corrected and in what version?  Also, is it true by turning off Word as the email editor that it fixes this?
Thanks, Cecilia
Rachael BRachael B
Hi Cecilia,
I have gone round and round with SFDC support on this issue.  They said this issue has been fixed for Outlook 2007 but since I am running Outlook 2003 they said they cannot develop the application to address older versions of Outlook as it would require a regression environment. 
It is true that by turning off Word as the email editor that when performing a send & add the email will always be added into SF with the due date (even if the email goes into a draft form).  However this is not a good fix for us as we all rely on Word to check spelling/grammar as we compose emails.  You can set it up to have spelling checked prior to sending but it doesn't catch all the grammar errors without Word as the email editor. 
The other fix/workaround would be to always send the email and then go back into the sent folder and add the email to SFDC.  This will also always add the email with the due date.  However this requires an extra step for each of my users which is also not a good fix. 
I run a report once a week and use the Data Apex Loader to update the due dates and this is the best fix for our business unit as a whole.  It doesn't require any extra steps from my users and they also don't have to worry that the emails they are sending out have possible spelling/grammar errors. 
In addition to this report I have had many of my users turn off the auto-creation of drafts (Outlook - Tools - Options - Preferences - Email Options - uncheck Automatically Save Unsent Messages) as the due date is lost when an email is saved as a draft.  This has reduced the number of emails that get into SFDC without a due date but there are still situations where the email has to be saved prior to sending (need more info; want a second set of eyes to read message; etc.) and also not all users will turn this functionality off.
Hope this helps and let me know if you have any other questions or if you hear of any other fixes or workarounds.
Cecilia and Rachael,
I wish I had Rachael's method when we were having this problem.  We were doing a lot of manual fix work.
We have since migrated to Office 2007 and the fix SF put in for this version does work.