+ Start a Discussion

Connect for Lotus Notes ==> Lotus Notes refuses to start

After installing "Connect for Lotus Notes", my Lotus Notes client refuses to start and neither Salesforce.com support nor our internal Lotus Notes support manages to help me fix it.
So, any ideas on how I should troubleshoot?
What I did thus far:
  • Added a registry value to make the log file more verbose => no real error messages that gave me any more clues
  • Checked my notes.ini file to make sure that it contains
    which it does
The only way for me to access Lotus Notes is to uninstall "Connect for Lotus Notes".

Any ideas or things I should be checking?
I really need to get this up and running, but being a rather new product there's not much support for it.

Thanks in advance,
//Johan Liljegren

Message Edited by JohanLiljegren on 12-21-2007 05:06 AM
Same thing happening with me. Have you resolved the problem. The notes.ini is correct here, too.
Unfortunately, no. The user who reported this to me ended up giving up trying to get it to work. After that I ran across another possible work-around, given to me from Premier Support:
  1. Shut down Lotus Notes
  2. Open the notes.ini file and remove the AddinMenus=sfdcmenu row
  3. Open Lotus Notes (should run ok now)
  4. Close down Lotus Notes
  5. Open the notes.ini file and put in the AddinMenus=sfdcmenu row as the last row in the file
  6. Open Lotus Notes
  7. The plugin should work better now

Try this and let me know whether or not it solved your problem.


Johan, thanks for the response. This DID NOT work.

I checked my own notes.ini to see where the addinmenus line was physcically placed and it is in the Middle of the .ini file.

This in really disconcerting!! The sad thing is that I have logged a case, and no one responds to it. I don't think the Salesforce people have a clue either.
Sorry to hear it didn't work.
I've had the same experience with support and the Lotus Notes plugin. It's such a new product and neither of them uses Lotus Notes on a regular basis, making it hard for them to troubleshoot.
I'll post more info in case I get it.
We have had the same problems, however, here are a few things that have worked to get it running:

Make sure Lotus Notes is closed:

  1. In the notes.ini file, find the line NSF_HOOKS=sfdcnsfhook, and remove the text after the "=", save the ini.
  2. You may want to reboot your system, then start Lotus Notes.
  3. If Lotus Notes opens, immediately go to the Salesforce Options in the Actions Menu, click the User Permissions tab and make sure to place the template name in the Custom Template Classes box that matches teh Database template (if you use anything different from the standard default template. Ours says "iNotes6".
  4. After you have configured the options, close Lotus Notes, go back and add the line "sfdcnsfhook" back to the NSF_HOOKS=, save and open Lotus Notes again.

If this does not work for you, you may want to consider reinstalling Lotus Notes. In doing a search on the machines that did not function we found there were multiple notes.ini files and sometimes they were located on a different drive (they had c:\ and a d:\ etc.) Essentially, our Lotus Notes guru was able to resolve the problem after all the above steps failed by doing an uninstall and reinstall and use the default locations for Lotus Notes.

I hope this helps. These are only recommendations based on how it worked in our environment and not any relation to a salesforce.com com expert or support individual.

Thanks, great set of tips! I'll make sure I'll try them out next time I experience this issue.
We usually end up with the user saying "Never mind" and leave it.
Thanks Nakeva! This worked for one of my users. Bulls eye... I really wonder why salesforce does not add these things to the Help & Training!!! Thanks again :smileyvery-happy: