function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Failure to connect via Crystal Reports

We're evaluating Crystal Reports and for generating reports from SF objects. I have properly installed within SF. I've downloaded and installed (separately) both CR XI (with SF Driver 3.0) and 2008 (without driver per CR's tech support) for developing reports.
When I attempt to Create New Connection/, a pop-up window appears pointed to and prompting for my SF userID and password. I have several valid SF accounts. No matter which account I try, CR returns a "Login error: invalid UserID or Password."
After two hours waiting to talk to a CR tech support person, they had virtually nothing useful to say ... basically they told me to get an SAP/BO tech support account which requires submitting an application. Their forums were impossible to navigate. CR looks like a great solution, but I'm underwhelmed with their tech support.
Is anyone using CR XI or 2008 to access SF objects? If so, any suggestions/advice re: connecting to SF?
Best Answer chosen by Admin (Salesforce Developers) 

Good news, there is a fix pack that can be installed after upgrading to Crystal 2008 SP2. To see the thread at visit:


To download the fix pack visit:


All Answers

Try appending your security token to the end of your password.
Yes, you need to append your security token as Gemini said.  If you're not sure where that is in Salesforce, go to Setup -> My Personal Information -> Reset Security Token and SF will send it to you in an email.

I have tried the suggested fix by appending my password with the security token but it replaces one error with another.


Logon failed.

Details: Unexpecteed error; nested exception is:

org.xml.sax.saxexception: invalid element in com.sforce.soap.partner.loginresult - metadataServerUrl


Am I using the wrong URL of


What version of Crystal Reports are you using?

Crystal Reports 2008 CR Developer version Product Type: Full




I can confirm that I too am having the same error with Crystal Reports 2008 CR Developer version connecting to


This is the built in connector.


The last time this worked was 9/9/2009. Only variables that I *know* have changed is the recent service pack 2 was applied to Crystal. 


Has anyone solved this or gotten the current version of Crystal 2008 with all of the latest service packs to connect to


Have you tried posting a note on the SAP Crystal Reports forum?  I did some searching there but didn't find any obvious solution for what you're describing.




Here is what I found. The issue relates to service pack 2 for Crystal Reports 2008. By downgrading (i.e. uninstalling/ reinstalling) to Crystal 2008 with service pack 1 everything is working fine.


Forums at SAP indicate this is a known issue and that a patch is being worked on. Nothing more at this point. 






Just an FYI - I installed SP2 today and received the same errors.  I scoured the Crystal forums for two hours to no avail.  This problem still exists with no known patch as far as I can tell...


Does anyone know of a fix other than downgrading?

I took the advice to uninstall and reinstall to SP1 and it works like a charm... I'll wait to download SP2 until they get the problem fixed but I have not heard of a fix for SP2 yet.

I just upgraded to SP2, and I'm now receiving the same error, as well. Anyone find a solution to this? Looks like it's been a few months.


I'd prefer not to downgrade back to SP1 because I was under the impression that SP2 was required for connecting to objects with multiple parents (per this page: 

I'm getting the same problem here: Same version of CR, same error message (yes, I added the security token).  Any idea if this is going to get a fix soon?

Good news, there is a fix pack that can be installed after upgrading to Crystal 2008 SP2. To see the thread at visit:


To download the fix pack visit:


This was selected as the best answer