function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Eclipse not pulling Pages or Classes for DEV org?

Hi, I'm running eclipse and I'm not getting my classes or pages for my dev orgs.  I have them for sandbox and production systems, but for my dev orgs I don't even get the folder for those 2 objects.  What's my problem...anyone...anyone?
When creating your project, what settings did you use in the second page of the wizard?

What folders exist under "src"?  Have you created any packaged in your dev org?
It would probably figure that way...Yeah, as soon as I edited the properties and updated my token (reset my password this morning) everything now shows up.

Odd that it even shows up for my 2nd developer org that I didn't refresh.  I must have had something cached, or saved or something, because all is good now.  I tried last week opening/closing, removing, re-adding the projects and it didn't work.  Don't ask me why, but it's working I'll go with it.
I'm having similar trouble. I created a new page via the web interface, then tried to refresh in the IDE (pages folder as well as the whole project), but the new page wouldn't download. Then I tried right-click properties and viewed the project components. I clicked the "Add/Remove..." button and tried then the "Refresh from Server" button. When it finished refreshing, the new VF page still wasn't there. The "pages" folder itself is checked and has the notation "Subscribed to new Visualforce Pages".

Just to try things, I looked at the "Apex Code" section (just above "Project Contents" in the Project Properties list). When I tried either of the two sliders (logging settings) on that page, I got the following error dialog, I'm not sure if it's related or important.

Well - never mind on the page not showing up - result of being logged in to too many orgs and creating the VF page in a different org than I intended.

I am though still curious about the error message I received.

(text copied here for future searches: "Unable to set string. Reason: Exception occurred while saving project preferences: /KV-dev/.settings/com.salesforce.ide.core.prefs." )
Not sure what is going on there but the Eclipse IDE support is not part of Visualforce - I have sent a note with a link to your post to the lead dev for the Eclipse IDE - we'll see what he has to say on this...
To clarify Doug's comment, this Eclipse error is definitely not related to Visualforce, though editing Visualforce pages through the IDE and the Metadata API is a feature fully supported by

This looks like some kind of internal Eclipse issue.  Can you post the underlying exception message?  You should be able to find it in one of two places in Eclipse:

1. Help > Show IDE Log
2. Window > Show View > Other... > PDE Log (not every Eclipse install includes this view)