function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Problem Syncing after Update v0.53


I've never had any problems prior to this month. I synced and somehow another 'salesforce calendar" was created on iCal. When this Sync problem occured , I decided to update to version 0.53. I use sf cubed for syncing only the calendar portion. Error message below.

[ISyncConcreteSession clientAcceptedChangesForRecordWithIdentifier:formattedRecord:newRecordIdentifier:]: you can't change the record identifier from to 00560000000z9OdAAI-Calendar: it is already associated with a different record.

Would not sync and and SFCD data was intact. I decided to delete salesforce on iCal and sf Cube and start from scratch, reinstalled sf Cube and tried to sync again. Big mistake, all events were deleted on SFDC. I thought it would sync to iCal only. I applied backup to iCal to restore and tried to sync but still get same error.

I use a MacBook Pro on OSX 10.4.11 Please help.
restore from your ical backup, delete one of the calendars, start SF3, goto preferences, and reset the sync history, then sync, that should work.
Thanks Simon.. that did the trick.. I'm out of the dog house now thanks to you.

Now I gotta go into SFDC and make all the old appointments 'Closed' Unless you know a way I can do it in iCal or any faster method.

Thanks again!


Message Edited by New User on 07-21-2008 06:50 PM
What's the actual problem ? does the sync fail and if so, with what error ? what's in the console log ?