function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Maildrop 2.0 released

I just posted the final Maildrop 2.0 build. You can download it from the project download page, or if you're already running Maildrop, just restart it, or pick check for updates to have it autoupdate.

Major new features include support for email attachments, the new buttonbar UI to replace the scripts menu, and the configurable search column for the 'What' search. Maildrop 2.0 runs on Tiger and Leopard, I have some ideas for the next version, which may mean its Leopard only.


I'm having some trouble with the Contact search portion. It's not returning any matched results for contacts that already exist. In fact, the results section itself seems to be missing. Changing the email address and clicking Search have no effect. Ignoring this and adding the email generates a new task with blank WhoId.

Just use the divider between the sections to make the section larger so you can see the results table.
Wow. Duh. I can't come up with anything witty enough to cover myself on that.
the new box to upload email into salesforce from maildrop doesn't seem to be working when an email has attachments.
I have tried to unclick 'add attachments' in maildrop preferences and that has no effect.  everytime i try to add an email into salesforce that has attachments, i get an error message..."maildrop got an erroro: Can't make file of attachment id "blah blah blah" of email id "blah blah blah" into type reference."
i can't add move forward and add the email into salesforce.  (i've attached a file of the error message)
thanks for your help!
what version of OSX and what version of Entourage are you using ?
OSX 10.4.1 and Entourage 11.2.1
Entourage 11.3.3 which the latest patches for office 2004 on OSX 10.5.5 works for me fine. It'll take me a while to get a Tiger machine setup to test (i don't think any of the beta testers were Tiger + entourage).

Is there any reason why you're not on the current patch versions of either 10.4 (10.4.9 i think), or Entourage ?
I was able to reproduce this on 10.4.11, it seems to be some weirdness relating to the saved compiled state of the applescripts, if you open the scripts with script editor on your machine (home -> documents -> microsoft user data -> entourage scripts menu) and re-save them, they'll work fine from the entourage scripts menu (but the button bar will not).

I'll dig into this some more.
hi there simon.  the software on my mac is up-to-date and i didn't realise there was an update for entourage.  i just tried to install it and everything worked perfectly, but it still maintains that my entourage version is 11.4.0.

i really would just like to 'go back to the way it was'...truthfully, it's not that important for me that i add the attachments into salesforce (would be nice--but certainly not that important).  i'm more interested in being able to quickly add the information contained in the email into salesforce.  is there a way to go back to the previous version of maildrop which was working fine for that purpose??

right now, anything with an attachment will not let me add the email into salesforce even when i unclick in preferences that i don't want the attachments uploaded.

thanks for your help.
As i said in my previous reply you can open/save the scripts in script editor to fix the problem.

alternatively you can go back to Maildrop 1.5, just by running the old version and picking reinstall scripts from the maildrop help menu.
Hard to overstate how incredibly cool this application is. GREAT work. Please keep it up.

A few feature requests:
- Make the button bar a bit smaller so that it does not obscure any of the email
- Add a feature that allows you to add calendar events - sfCubed is a bit of overkill (I'd like to be able to add calendar items on an ad hod, as needed basis.

thanks for all your help simon!  i'm back on maildrop 1.5 and it's working again!  when i get my new mac, i look forward to being able to use all the new features!!  it really is a great tool!!
thanks again.
I'd just like to confirm that opening the scripts in the script editor and doing a Save As to replace them does help.  My issue was after updating to 2.0 the scripts and button bar simply didn't do anything.

Entourage 12.1.4  /  OSX 10.4.11

Great App! (will MS let you put the buttons in Entourage's own tool bar?)
I just posted Maildrop v2.1 to address the applescript related problems on OSX 10.4.

This will likely to be the last version to run on Tiger, future versions will require at least 10.5.