+ Start a Discussion

Can't restore or recreate a class in a managed package

I posted this message yesterday, but it was deleted. Don't know why.


We have a Salesforce integration implemented as a managed package. I have some test classes which provide test coverage for the apex code in the package. Yesterday I was attempting to move the test code into the classes the test code covered. I copied the test code, deleted the class "TestRecordTypes," and created a test function in the controller class. After running the test, code showed as not covered even though it showed as covered when the test function was implemented in a separate class.


When I tried to move the code back into the class I was unable to edit or recreate the original TestRecordTypes class. If I create a new class w/ the same name in Eclipse the original code shows in the newly created class (???), but if I try to save I get prompted w/ "Remote instance has been updated... Use synchronize perspective..." but the synchronize perspective won't let me save the restored code in the deleted class.


I tried to delete the class using the API, but I get a message like "The class is not deletable."


So, the deleted class still shows in Setup / Develop / Classes. I can't edit it, or make it go away so I can recreate the class


This is bad enough, but when checking for responses today I find my original post was deleted.


Does anybody have any input on this one? Rock on my left, hard place on my right.




Ron HessRon Hess

your post was probably moved to an approperate board, this board is focused on visualforce. 

There is an a packaging board, that is where you should post your question.


AppExchange Directory & Packaging

Message Edited by Ron Hess on 04-03-2009 08:18 AM
Of course you are right. Thanks much.