function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Lexiloader - no success, no errors



I'm new to SF and am working in Developer mode. I tried an insert of 30 records via Lexiloader (such a relief finding that it exists and that I don't need to run Parallels and Windows!) and it ran, showed no errors, but no success either. And no records were inserted (0 successful inserts and 0 errors).


The custom object I'm inserting into has two master-detail relationships - is that a limitation?


The custom object has the following fields:

MF_Transactions_Id (Name) = Autonumber

Posted_date_c = Date/Time (defaults to NOW())

Rate_c = Formula(Currency)

Scheme_c = Master-Detail(Scheme)

Squirrel_c = Master-Detail(Contact) [filtered]

Transaction_c = Picklist

Transaction_date_c = Date (defaults to TODAY())

Units_c = Number(8,4)

Value_c = Currency(10,2)


In my csv I have all the above fields except the autonumber and the formula field. In the two Master-Detail fields in the csv, I have entered the value that shows up in the Name field in the respective Master. E.g., for Squirrel_c where the Master is the Contacts object, I've used "Mr. Bob Dylan". Here's a sample line:


2011-06-23T00:00:00.SSSGMT+5:30,Templeton India Treasury Management Account,Mr. Bob Dylan,Dividend,2011-05-1T00:00:00.SSSGMT+5:30,0.088,133.75


Any ideas what could be causing this to bomb?








You may alread have solved your problem, but in case not — the Lexiloader needs the Salesforce ID for the Master-Detail relationship fields. "Mr. Bob Dylan" is not going to work. You need to replace that with the 15-character Salesforce ID for Bob Dylan's Contact record.


Also, the Lexiloader should have produced successes and errors files. Check the last column of the errors file and you will see a description of each error.