+ Start a Discussion
Diane CochranDiane Cochran 

Google Visualization not showing image in IE 8 native mode inside VF page.

I've managed to get a google visualization gauge on an vf page, and it seems to work in all browsers (Safari, Mozilla, IE < 8) except IE 8, unless I view the page in compatibility mode.  For the life of me, I don't see anything going wrong, no errors in the javascript, just no image.


Has anyone else run into this problem and might have a solution?

Did you ever find a fix to this? I am running into the same problem.
Diane CochranDiane Cochran
Sorry, I haven't.  The solution has been to get people to view salesforce in compatibility mode rather than native.

The truth is, there is a solution. The following code needs to be inside you Visualforce page:


<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />


BIG problem: this line of code needs to be in your code BEFORE any .css files are loaded. How can I control that? I can insert the line of code, but it always loads after the .css files, and therefore is useless to overcoming this problem. Does anyone have an idea? 


OK, after much pain....I found that using:

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" /> in the <head></head> section


and killing all .css files in the visualforce page by setting standardStylesheets="false" and then re-adding them manually after the meta tag will allow the visualization to run by forcing the browser into compatibility mode. Talk about a nightmare.