function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

content Type error

Hi All,

I am using :
tabstyle="Member_Value_Plan__c" title="Member Value Plan"
sidebar="false" showHeader="false" standardStylesheets="true"
contenttype="application/msword" cache="true">

I have used the following formats:

Actually, everything is fine if the file can be opened or saved in the doc format not into the web format.

In 2003, the page contents displays as in the HTML format like everything comes into the table format.

If I open the file and try to save it this file by default saved in web format,
But if I choose ms word format (Word 97 – 2003 Document) from the Save as Type list than
the new file gets open in correct ms-word format without showing contents into the table.

Any suggestions please.

Nitin Gupta
Message Edited by NT on 05-13-2009 07:44 AM

Having similar issues.  I am not able to generate a page break on the "Ms Word" or RTF Content Type.


Any help is appreciated.


Luis A.


Hi Luis,


Were you able to solve the issue with the page breaks. I am having similar issues with power point content type where all the data is getting loaded into a single slide.


Do let me know in case you have found a solution.




Sorry, I didn't find a solution. I ended up using a different approach rendering doc as PDF.

Using pdf is not an acceptable solution.  Has anyone been able to use msword without formatting issues? 


I am not able to manage column width on the msword content type.


This looks like it really should be a case that Salesforce solves.  Can someone please help?


If all you are looking to do is add page breaks, you can set up a page break like this...


<br clear="all" style="page-break-before:always" />



What I haven't been able to get to work, maybe somebody knows, is getting the Page numbers to show up and getting it to open in Print View.  I think it has something to do with not having access to the <html tag in the visualforce page since the same page in plain html does eveything fine for me.  I tried adding my own <html tag after the <apex:page tag, with all of the microsoft schemas in it but it isn't working for me.  Anyone know how to get that stuff to work????




I tried


<br clear="all" style="page-break-before:always" />

but it does not work. Has anyone found a solution to add page breaks where contentType="application/vnd.msword"



<br clear="all" style="page-break-before:always" />