+ Start a Discussion

Not able to Access Chatter feeds on public site

Hi All,


Few days back i created a site vf page showing feed of my custom object (Job).  Every thing was working fine. My object feed a visible on site and i was able to add new feed  comments. 


But from last two three day i am not able to access the vf page with feed object (Job__feed). I try to debug for the cause. i am getting following debug logs :


12:44:25.851|CODE_UNIT_STARTED|[EXTERNAL]|01pT00000005Mon|DebugPage invoke(debugNow)



12:44:26.112|EXCEPTION_THROWN|[12]|System.VisualforceException: Access to entity 'Job__Feed' denied





12:44:26.324|EXCEPTION_THROWN|[15]|System.VisualforceException: Access to entity 'Job__Feed' denied



12:44:26.324|CODE_UNIT_FINISHED|DebugPage invoke(debugNow)




Debug logs say: System.VisualforceException: Access to entity 'Job__Feed' denied.  I try to look for setting though which i can grant access to this Job__Feed object. But i found none. More over thing was working fine before getting this error without doing any access setting for feed objects. 

Is there any chatter update in winter 11 which is limiting the feed object access to force.com sites. I am doing all this on my sandbox org.

I really got stuck in this , as every thing was done but finally not running. 

Any help from you guys will really appreciated.  Thanks in advance 








chatter is not available for sites and portal.


Thanks Bulent for the quick reply. 


As you are saying chatter is not available for sites. But i created a sample site page showing all my custom object (Job__Feed) feeds and i was able to comments on the feeds also. Every thing was working fine. 


So is there some thing in the winter 11 which is limiting the access to the chatter. 


hi all,


i think chatter doesnt work with sites.


i tried to retrieve the user,currentstatus on my site and i was successful in displaying all the user's current status because the query was on user object but similarly when i tried to query on newsfeed and display the results on site i was UNSUCCESSFUL.


but the same page is working properly when i only run the VF page.