function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
David VPDavid VP 

CMSForce 2 is now on the AppExchange

Hi all,


Quite a few of you have asked me about the availability of CMSForce 2.

I'm very happy to announce that you can now find it on the AppExchange. On the listing you'll find a short demo video that will get you up to speed on the new features. (central management console, folders to organize your content, in-site editing, friendly urls, ...)


I'll also include a shameless plug here : If you want to see it in action 'live', come to my 'Increase Lead Volume with Compelling Landing Pages' session on wed 8 at DreamForce.


Hope to see you there! In the meantime : if you have questions, just drop them in community boards.





Michael HaubenwallnerMichael Haubenwallner

Hi David, thank you for releasing CMSForce2.


I had a problem installing into my developer account ('Install failed') - is the app source available for download?


Package components error list:  






Apex Classes(01pA0000001OqGV)



System.NullPointerException: Attempt to de-reference a null object
Class.HomePageController.t1: line 69, column 51
External entry point

David VPDavid VP

Hi michael, do you have at least one Active Site in your DE org (before you start installing?)

Let me know if that solves it for you.
Michael HaubenwallnerMichael Haubenwallner

Yes, there is one active site.


There was none on first attempt, throwing an additional error:

Apex Classes(01pA0000001OqBk) cmsforcesetupcontroller.t1()
System.AssertException: Assertion Failed
Class.CMSForceSetupController.t1: line 94, column 3
External entry point

David VPDavid VP

I've sent you a private message. We'll figure this out.


I was looking for a simple CMS solution to build a simple site.  I installed the CMS Force 2 today and can't seem to figure out how to use it.  Where do I get info?  I was hoping to not have to higher more people. 


The more I think about it I beleive that Salesforce was designed to develop a consultant industry.  Despite the claim that using it is easy I have not found that to be the case at all in the last 3 years.  While I attempt to keep up with dizzying amount of new capabilities it sure would be nice to actually use them someday.  Maybe a consultannt that reads this can tell me how to use SFDC without a $100+ per hour consultant. 

Michael HaubenwallnerMichael Haubenwallner

There are 2 instructional links on the CMSForce 2 Appexchange listing:

- Video

Installation and User Guide


Hth, Michael


David VPDavid VP

To 'New User' : With all due respect but I tried to make CMSForce as easy to use as possible.

Michael already responded with links to the setup guide (there are somthing like 5 parameters to configure and you should be good to go, if you're stuck somewhere, ask on the sites forum : Myself, a lot of colleagues and community members monitor those and we all help out as much as we can - all on best effort basis. On the bright side : CMSForce is free and we don't charge a fee :-) )

I also want to make clear that this is not an official Salesforce product. It is one of many Labs product (built by Salesforce employees on a goodwill basis, all of them out of shear passion for the platform).


Consider the alternative for setting up your own website :

- get the right hardware

- install a server operating system (and configure/secure/patch it)

- install a database

- install a web server and an application server

- install a CMS system or hardcode everything in Java, .NET, ColdFusion or any other language you prefer

- setup a firewall

- setup backup & disaster recovery


and you might not need it but thanks to the platform you also get :

- reporting

- collaboration

- workflows/approvals

- reporting

- mobile access

- security

- 3x upgrade a year (no consultants needed here)

- ...


Having said that : There will always be a place for consultants. The Cloud can be really easy, and a lot of our customers do a lot themselves, but depending on the size and complexity of your projects it can be a good idea to include professionals that have the experience and knowledge to get you to your goals faster (and that statement is true for any industry, not just ours).


I'm not out to offend or start a heated discussion. I just wanted to clarify my humble view on this.




David -




Now that a 25 page user guide shows up I have less questions.  As you can imagine even if I were a developer this app would be difficult to understand without instructions.  I'm not a developer.  I just want to be an end user that currently has no budget for needed consultants.  I only want to make a simple web page hosted on my SFDC account.  This shouldn't be hard.  I do appreciate the help on this forum but keep in mind not everybody that buys SFDC is a developer or consultant.  Customers like me just want to have tools that make my job easier not harder. 


Hi, I am also having that same problem installing (and I do have one active site).  Would be be very grateful for assistance as I'm really keen to try it out!


John Davies

David VPDavid VP

Hi John,


I've sent you a private message. I'm not sure yet why the error is happening but I know how to get around it. Get in touch with me.




I'm anxious to try out this tool, but I've tried installing it 3 times into my Developer org and get the same result.  I follow all the instructions exactly, and when I go to the CMS Console, it hangs up trying to load the site navigation tree (Site, Page Templates, Web Forms, Setup).  It just says "Loading..." with the spinning circle.  Any idea what it's trying to do at that point?  Before the last attempted install, I uninstalled all apps from the org.  Yesterday, I created a fresh Developer org, and CMS Force installed and works just fine, so does that say there is some artifact in my "non-virgin" org that is affecting this?


David VPDavid VP

I've had 2 reports of that today. Seems to be a bug but I can't reproduce it myself.

Contact me on private message if you do and we'll figure it out.

David VPDavid VP

lenzrg :

Disable 'development mode' on your user detail record and you should be fine.

Let me know if that solves it.




That did the trick - thanks!!


When completing the installation of CMSForce 2 today and following the instructions, I get to the CMSForce setup section, enter my Preview URL for my website and Salesforce Domain url. But there is no SAVE button for me to save this information.





Is there an example of a site that has been built using CMS Force 2 that I can see?  A link to a new site would be great. 

David VPDavid VP



If you have new questions, post them as a new on the boards (this thread is getting long).


@Newbie : The 'Save' button for preview url only shows up if your profile is 'System Administrator'.


A way around is, is to modify the CMSForceSetup visualforce page.


On line 25, change :


<apex:commandButton value="Save" action="{!save}" rendered="{!IF($Profile.Name == 'System Administrator', true, false)}"/>



To :


<apex:commandButton value="Save" action="{!save}"/>


And you should be fine. Make sure to make that VisualForce page unaccessible for other profiles. You don't want your users to make changes to this.



David VPDavid VP

Examples of websites on our Sites technology can be found at :


There's quite a few companies out there that use CMSForce but since I haven't asked specific permission, I'm not going to share that.

If you know how CMSForce works, I'm sure you can spot the ones that are ;-)


I'm having the same problem during install. I checked installation's guide, verified prerequisites (at least 1 active site). I'm trying to install in my production box ( (Admin user, Development Mode "of").  I've seen you provide solution  for "free" :smileyhappy:.....  the error is the same:



System.NullPointerException: Attempt to de-reference a null object
Class.HomePageController.t1: line 69, column 51
External entry point


thank you in advance

David VPDavid VP

Try 'ignore test failures' when you install. It's a rare problem in one of the test classes. I haven't had the opportunity to update the install yet.

If that doesn't work, install from this link :








PERFECT NOW  everithing is  ok  


I thought too late to the solution "ignore error during install"  The same things happened during installation of another apps and we solved with an "IGNORE".

Thank you so much !



The link to the user guide isn't directing me to any content.  Is there a way i can get access to that.  I'm having a major issue trying to get my site to appear on a public domain (keeps requesting authentication with a username and password).


I'm sure the user guide will help me decipher what I'm doing wrong.


Did you ever get that resolved?


I'm getting the same error on installation attempts into sandboxes of 2 different organizations.


I really like CMSForce 2 - much easier than the first one - Thank you for providing this tool!


When I installed CMSForce 2, I had to check the box to ignore apex warnings in order to get it to install. But now I have a problem in that I am trying to move something (unrelated to CMSForce) from sandbox to production, and failure of HomePageController is creating a problem because it won't let me move anything. The error is


HomePageController.t1()	Class	69	51	Failure Message: "System.NullPointerException: Attempt to de-reference a null object", Failure Stack Trace: "Class.HomePageController.t1: line 69, column 51 External entry point"

 This is the line with the error from the homepagecontroller. Can you tell me what to change? Thank you

        HomePageController hpc = new HomePageController();
        PageReference redir = hpc.redirect();       
        System.assertEquals('/apex/page?pageid='+pg.Id, redir.getUrl());
        The line above is the error line
        pg.Home_Page__c = false;
        update pg;
        HomePageController hpc2 = new HomePageController();
        PageReference redir2 = hpc2.redirect();     








David VPDavid VP

Hi Jenna,


You can safely comment out the offending line. It will not take away any functionality.

It's a bug in the test.


Thank you!

Richie CNRichie CN

Hi there,


i've installed CMSForce2 but i cannot read the Installation and User Guide given on link at the AppExchange.

I'm really glad to work with this App. But the right Installation and User Guide will help to for start building a website.


I hope you can give me (us) a new Guide.


06/04 EDIT: now i notice the guide is probably correct, with the letters are white?


07/04 Problem solved! I'm working on a Macbook Pro. But Safari isn't compatible with showing the Guide. At the office i tried opening the Guide in Google Chrome, and that work just fine!


With Regards,




I've tried to access the user guide - with no luck. I've tried IE, Firefox, Chrome and Opera - I've tried seeing if the text is white etc.  No luck.  I'd love to get a CMS working from the site(s) I'm building.



David VPDavid VP



I'm mailing you the guide in word format right now, hopefully you'll be able to read that.

Strange that Mac's have so much trouble opening the pdf (and I was just thinking about moving to Mac Book Pro myself :-)






I tried to install CMSForce 2 today and it failed with an error stating I had to uninstall CMSForce first.  I had done that already and can't seem to see any signs of the previous version.  Can you provide some guidance?  Thanks!


wow this looks awesome.  i got it installed and am following the guide.


i've created a landing page and am working on adding a web form now and am having a problem.  i want to add campaign member fields, but not all of them are showing up.  seems only custom fields appear, and not default ones like first name, last name, etc.  am i doing something wrong?  any help would be greatly appriciated.  thanks:)

UT UserUT User

Hi! Just installed CMSForce 2 yesterday and following the guide.  I've saved a page template 3 times to the saple templates folder, but it doesn't appear in the folder.  Any thoughts on this?


Thank you!



Thanks for post..

Could you tell me how it is working any logic behind that or anything like that...

I have a  webform to the page developed using CMS console
But when I click save, i data is saved in the database but not redirecting to the return URL.
Can anyone help me.