+ Start a Discussion

Force.com Authorization Required error message

I created a survey to using visualforce and force.com sites. when i test the force.com survey link with the case.id, account.id and the contact.id in the link, clicking the submit button I get the Authorization Required error. Why won't the information go back to the survey object with that info?




Is this a public access site?  If so, it may be that the code is throwing an exception - I've found that if that happens, the platform attempts to send you to an error page.  As the error page is only available to authenticated users, you get the auth required.


Have you tried turning on debug logging for the public access user for the site to see if there is an error occuring? 


You need to give the access permissions through the Public Access Settings from site details page for the visulaforce pages and objects for the site guest users to access them on site.

I had the same issue. It turned out that my controller class had "with sharing" enabled. I changed this to "without sharing" and it then worked.