+ Start a Discussion

The Chatter Connect API is not enabled for this organization or user type

I tested my app in the DE org and everything worked fine.  I went to connect it to our main org and I got this:

{"message":"The Chatter Connect API is not enabled for this organization or user type.","errorCode":"API_DISABLED_FOR_ORG"}


I know that our admins are going to resist enabling anything that they don't think is necessary for business.



1) Is there a doc somewhere on how to enable it properly?  (I couldn't find it)

2) Is there a doc from Salesforce that outlines the security best practices and soothes the mind of an average admin.  Things that I am looking for in a doc like that is that via Chatter API no one will be able to get the customer data, change the customer data, get any opportunity data or anything like that.


Thank you!!


The Chatter API is in developer preview, so it is only available in developer orgs.  The only way to turn it on in your production org is to join our pilot program.  Please contact your sales rep or SE if you want to join.  


As with any other API, once the user approves the API client, the API client can do anything that user can, including reading and writing data.  Users should only approve applications that are trusted.  


is it enabled for the general population now?


yes, the API is now GA.


I couldn't find a place to enable it.  I used the search for all the Chatter settings on my admin page and there was nothing to enable API.  What am I missing?




The Chatter API is default on in all organizations that have chatter, there's nothing you need to do.  Note however that the API obeys the "API enabled" user profile perm, so some users may have it off if their Admin turned it off for their profile.  See http://developer.force.com/chatter-api for more information.




I am running into the same issue. I have a Visualforce page which uses the Connect API to display the chatter feed for a record. When I access this page directly, it shows up fine. When I add it to my Force.com site and attempt to access it using the Guest user, I get this error "The Connect API is not enabled for this user type"


Now this user has read permissions to everything shown on the page. Also his profile has the "API Enabled" permission.


How can this profile get access to the Connect API?








Alyssa Woodliff 1Alyssa Woodliff 1
Hey guys, did anyone figure out how to fix this? I am getting it with the damn Einstein Analytics for one profile. I don't know how to correct it for those users. 
Mani Gunasekaran 26Mani Gunasekaran 26
@Alyssa , Not sure if you have resolved the issue, I experiecned the same issue, on investigation i found the profile is not enabled to access API. after adding this permission issue got resolved.