+ Start a Discussion
AmigoAmigo 

Force.com Site can be seen on https but not http

Dear all,

 

I just create a new Force.com Site to handle registeration with Force.com Frree Edition. Strangely, this site may be viewed with https but need authentication with http:

 

http://free-12415f14c3a-124e539428a-125109c507b.force.com/

 


https://free-12415f14c3a-124e539428a-125109c507b.secure.force.com/

 

I made a copy of my environment in sandbox. The Site in sandbox has no problems at all. Both may be seen without any problems.

 

The start page is simple html text without any apex or controls. It shouldn't do anything with authentication.

 

I have check the profile, object, and data access setting but still have no idea at all. Is there any one could be me any suggestion to fix the issue?

 

Please help!

 

Best regards,

 

Amigo

Message Edited by Amigo on 01-12-2010 08:18 AM
Best Answer chosen by Admin (Salesforce Developers) 
BulentBulent

okay, this is a caching bug on our side, here is the workaround until we fix this:

 

1- drill down to the login hours page (site details>public access settings>edit login hours

2-  create login hours for each day, save

3- deletelogin hours you just created on the public access settings page. Don't use the Clear link on the login hours page

  

 

All Answers

AmigoAmigo

A shorter VisualPage as below:

 

http://free-12415f14c3a-124e539428a-125109c507b.force.com/AtcCampaignThankYou

https://free-12415f14c3a-124e539428a-125109c507b.secure.force.com/AtcCampaignThankYou

 

Source Code:

<apex:page cache="false" sidebar="false" showHeader="false"> <apex:insert name="header"><!-- 網頁頁首--> <c:SiteHeader /> <center><h1><font face="微軟正黑體">註冊資料送出</font></h1></center> </apex:insert> <div style="font-family: Arial Unicode MS"> <center><p>您好,我們已經收到您的資料,會在兩個工作天之內與您聯繫,確認您的寶名資格,謝謝!</p></center> </div> <apex:insert name="footer"><!-- 網頁頁尾--> <c:SiteFooter /> </apex:insert> </apex:page>

 

Gregory512Gregory512

I'm having the exact same problem, exactly as you described.  I wish I had an answer.  I'll be following this thread to see if anyone has a solution.

BulentBulent

did you IP restrict your site? Take a look at site details > public access settings>IP ranges

 

if you IP restrict your site you can only access it via the secure url and within the allowed IP ranges 

Gregory512Gregory512
No ip restrictions on my end.  I can access the default web address fine in my sandbox with a site that has identical public access settings.  Really strange..
EIE50EIE50

Hi,

 

details > public access settings>IP ranges

 

--No login IP ranges specified. Users from any IP address are allowed to log in.

 

Also made true for Require Non-Secure Connections (HTTP) . But whenever user tries to login, the browser comes up with security issues ( --There is a problem with this website's security certificate.)

 

Thanks

 

 

BulentBulent

ssl cert warning..

do you see that on your sandbox or on your production site? 

Message Edited by Bulent on 01-12-2010 11:59 AM
Gregory512Gregory512
I don't see an ssl cert warning.  Where would it be?
BulentBulent
sorry SSL cert warning was a question for "EIE50" relates to his question.
EIE50EIE50

Hi,

 

Its in my sandbox. Will it be fine if i move that in to production?

BulentBulent
correct. if you are getting SSL cert issue then it's sandbox related your production org should not have this issue
BulentBulent

for the site working with https but not with http question:

 

can you let me know if you ever enabled login hours for your site (site public access settings>login hours) ?

I'm not asking i it's enabled now, but I'm trying to find out at some point if you enabled and then may be removed later or not. 

BulentBulent

okay, this is a caching bug on our side, here is the workaround until we fix this:

 

1- drill down to the login hours page (site details>public access settings>edit login hours

2-  create login hours for each day, save

3- deletelogin hours you just created on the public access settings page. Don't use the Clear link on the login hours page

  

 

This was selected as the best answer
AmigoAmigo

Dear Bulent,

 

About UP restrict, I am sure I didn't have any restriction on IP.

 

About SSL Cert Warning, I saw this warning on 2010/1/11, but none on 2010/1/12 to 14 while accessing with htts.

 

About login hours, when I have the access problem with http, I have try to setup manually to enable access during my test period. Unfortunatedlly, it still doens't work. Therefore, I cancel the restriction.

 

About cache, as you may seens on my first code, I have disabled the cache with cache="false". 

 

Dear EIE50,

 

About SandBox, here is what happen with my case.

 

1. Build on production org. Haveing probleming with http, fine with https.

2. Clone my production to Sandbox. Before 2010/1/13, haveing no problems with http and https in the Site provided by Sandbox as below:

 

http://free-12415f14c3a-124e539428a-125109c507b.atcsandbox.cs1.force.com/

 

https://free-12415f14c3a-124e539428a-125109c507b.atcsandbox.cs1.force.com/

 

Noted: https has SSL Cert warning on 2010/1/13, but fine on 2010/1/11 and 1/12

 

free-12415f14c3a-124e539428a-125109c507b.atcsandbox.cs1.force.com 用了無效的安全憑證。

 

憑證只對下列名稱有效: (This cert is valid to following names)
  *.cs0.force.com , *.force.com , *.secure.force.com , *.cs0.visual.force.com , *.cs0.content.force.com , *.cs1.force.com , *.cs1.visual.force.com , *.cs1.content.force.com , *.cs2.force.com , *.cs2.visual.force.com , *.cs2.content.force.com , *.cs3.force.com , *.cs3.visual.force.com , *.cs3.content.force.com 

 

(錯誤碼 (error code): ssl_error_bad_cert_domain)

Dear Grogery512,

 

Thank you for your quick reply. Glad to see your prompt reply to Bulent.

 

To All,

 

I am living in Taipei with is GMT + 8 and cannot answer as your are talking. Thank you for all your help to continue this topic.

 

My MSN is : amigoccs@hotmail.com Feel free to add me if you need to online chat with me. 

 

Have a nice day!

 

Best regards,

 

Amigo

AmigoAmigo

Dear Bulent,

 

Yes, it works. I may see my Force.com Site with http and https. Both works great!

 

Thank you very much!

 

Have a nice day! 

 

Best regards,

 

Amigo