+ Start a Discussion
ScriptMonkeyScriptMonkey 

Insufficient Privileges error when running a flow

I have a hunch I'm missing something obvious, but I've finished making a flow, set as start location, saved it to make sure there were no warnings, then clicked "run" and I get:

 



Insufficient Privileges

 

You do not have the level of access necessary to perform the operation you requested. Please contact the owner of the record or your administrator if access is necessary. 

 

 

Anyone have any ideas as to what I'm doing wrong?

 

*Note:  I'm using the cloud Flow Designer. I use a mac, so I can't even try the locally run version

 

Best Answer chosen by Admin (Salesforce Developers) 
ScriptMonkeyScriptMonkey

I found the problem!  Sorry to ask, then answer it myself, but I thought in case anyone else was being as thoughtless as I was, they might want the answer.

 

There's a "flow User" flag on users which I'm guessing defaults to not checked.  Check it, click save, and all is good.

 

Sorry about the dumb question.

 

All Answers

ScriptMonkeyScriptMonkey

I found the problem!  Sorry to ask, then answer it myself, but I thought in case anyone else was being as thoughtless as I was, they might want the answer.

 

There's a "flow User" flag on users which I'm guessing defaults to not checked.  Check it, click save, and all is good.

 

Sorry about the dumb question.

 

This was selected as the best answer
davidsworldukdavidsworlduk

If it's a dumb question then you're not alone. Thanks for finding the solution, been having the same problem!

 

David.

Arbitrary AppirianArbitrary Appirian

Thanks for not only asking the question but also coming back and describing the resolution.  

Wendy Frame 9Wendy Frame 9
Thank you, ScriptMonkey! You saved me some time figuring this out.
Jacob KozeraJacob Kozera
Just found this thread.  It has been almost 2 hours of frustration that this just solved.

Thank you!
 
Leah KoppermanLeah Kopperman
This is super helpful. Does anyone know if there is a way to enable this on the profile level, instead of doing it user by user?
Leah KoppermanLeah Kopperman
Ha, just like the OP ScriptMonkey, I figured this one out on my own and now I'm paying it forward. Under Profile > Systems Permissions, in the "Systems" section there is a permission called "Run Flows".
Jessie Rymph 3Jessie Rymph 3
My user still can't launch a flow. I have both "Run Flows" checked on the profile and Force.com Flow User checked on the profile. What's missing?
Jessie Rymph 3Jessie Rymph 3
AH ha! The user needed access to the visualforce page that launches the flow.
Steven BermanSteven Berman
Can someone from Salesforce please contact me to help with an "Insufficient Privilege" error I'm receiving when trying to access "Short Lists" 
 
Daniel Fernando SoaresDaniel Fernando Soares
I was having this same problem, thanks a lot for having the answer!
Steven J. CocchiarellaSteven J. Cocchiarella
Thanks. I remembered seeing that setting but couldn't find it... I was looking under profile. Strange that it is configured on the user level.
Kristine Sheehan 5Kristine Sheehan 5
Thank you for posting this! 
Rebecca RallsRebecca Ralls
There is another possible area where you may need to grant access to a flow.  Just like you give access to Apex Classes or visualfoce pages, some flows require that you grant access to the flow.  There is a related secion of the profile called "enabled flow acces" where you must add the flow.  So if you've got run flows active, and you're still having issues, try this. 

From here: https://help.salesforce.com/s/articleView?id=sf.flow_distribute_security.htm&type=5
If Override default behavior and restrict access to enabled profiles or permission sets is selected for an individual flow, access to that flow is given to users by profile or permission set